forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libsfml: Bump to version 2.4.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Lars Wendler
committed
Feb 11, 2017
1 parent
caac5cd
commit 53d1741
Showing
2 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libsfml-2.3.2.tar.gz 22203359 SHA256 55e7c864938e03ceb7d6d05c66f8e0dc886e632805d0ae17c222da317ba14e4c SHA512 db491b57595d567e6ce47d081fd6292bff924678fe0a61243f2dfa23df187d2c58f3bd91ea13447e49bec5f888777f338bfa461aec86d9328710623d73aeb424 WHIRLPOOL acef2cc6775ee16151cf5809e78ede2e10f5a5ae51d5d90851a17f8b73b4f599e4eb11bc16bca1db53db507906936f149a38a5670e8a81797ac5a5165d9adc83 | ||
DIST libsfml-2.4.0.tar.gz 24578301 SHA256 712da18445a1dcbb717b010d9b19889222c95b6632c343457aa61712cbe1d76b SHA512 76d1c0421b905c2c04324e591d2c309eb9547eae3917f7df966fc5e462ef4e10198f36c5d089273ec0fcff49fd42b7cb82d166c4134ccd2308b47082d2a3354c WHIRLPOOL d6304e52e280f32a067695f386cea7921aaf203fb28c8d4ad181533130b57bda04334ec0d3bc7013673a7404e0d3e88fb19766840c669118c75544a5956e6deb | ||
DIST libsfml-2.4.1.tar.gz 24573418 SHA256 f9d1191b02e2df1cbe296601eee20bdf56d98fb69d49fde27c6ca789eb57398e SHA512 50b2bdd914faccb9e44409f7a3b20909efef034be15e298c34710eafc52b36494272e4f5f9c882516fa1312c2e2ff3ebff0dd5246f193724ea6bc5be9ef8530f WHIRLPOOL 2528c1906c085f9b574414476f3f5ec5a85bc358c57dc47b91fe4c8a5398a771893825a6ad1671f8fb144a6f13634bfa5f186a2b34b58e1e405eac25677b71ca | ||
DIST libsfml-2.4.2.tar.gz 24576150 SHA256 cf268fb487e4048c85e5b2f53d62596854762c98cba1c1b61ccd91f78253ef4b SHA512 8acfdf320939c953a9a3413398f82d02d68a56a337f1366c2677c14ce032baa8ba059113ac3c91bb6e6fc22eef119369a265be7ef6894526e6a97a01f37e1972 WHIRLPOOL 6ea18fae58ab90235158abffc1492eccbdd8f8173a6c5ea3a55b447a47d75ecc53a4615996fff16f9e826e417a7d0028cf9366aed6913aec5fbc5d9c592054de |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils versionator | ||
|
||
MY_P="SFML-${PV}" | ||
|
||
DESCRIPTION="Simple and Fast Multimedia Library (SFML)" | ||
HOMEPAGE="http://www.sfml-dev.org/ https://github.com/SFML/SFML" | ||
SRC_URI="https://github.com/SFML/SFML/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="ZLIB" | ||
SLOT="0/$(get_version_component_range 1-2)" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug doc examples" | ||
|
||
RDEPEND=" | ||
media-libs/flac | ||
media-libs/freetype:2 | ||
media-libs/libpng:0= | ||
media-libs/libogg | ||
media-libs/libvorbis | ||
media-libs/mesa | ||
media-libs/openal | ||
sys-libs/zlib | ||
virtual/jpeg:0 | ||
virtual/libudev:0 | ||
virtual/opengl | ||
x11-libs/libX11 | ||
x11-libs/libXrandr | ||
x11-libs/libxcb | ||
x11-libs/xcb-util-image | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
doc? ( app-doc/doxygen ) | ||
" | ||
|
||
DOCS=( changelog.txt readme.txt ) | ||
|
||
PATCHES=( "${FILESDIR}"/${PN}-2.2-no-docs.patch ) | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
src_prepare() { | ||
sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \ | ||
doc/CMakeLists.txt || die | ||
|
||
default | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DSFML_BUILD_DOC=$(usex doc) | ||
-DSFML_INSTALL_PKGCONFIG_FILES=TRUE | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
insinto /usr/share/cmake/Modules | ||
doins cmake/Modules/FindSFML.cmake | ||
|
||
if use examples ; then | ||
docompress -x /usr/share/doc/${PF}/examples | ||
dodoc -r examples | ||
find "${ED}"/usr/share/doc/${PF}/examples -name CMakeLists.txt -delete | ||
fi | ||
} |