Skip to content

Commit

Permalink
games-puzzle/world-of-goo-demo: Use Slackbuilds mirror, EAPI 7
Browse files Browse the repository at this point in the history
I tried to add USE=bundled-libs but the ancient Vorbis libraries clash
with system Vorbis libraries pulled in via PulseAudio.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Apr 28, 2020
1 parent df287b4 commit 53e57f0
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 69 deletions.
69 changes: 0 additions & 69 deletions games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r2.ebuild

This file was deleted.

52 changes: 52 additions & 0 deletions games-puzzle/world-of-goo-demo/world-of-goo-demo-1.41-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit desktop eutils xdg

MY_PN="WorldOfGooDemo"

DESCRIPTION="A puzzle game with a strong emphasis on physics (demo version)"
HOMEPAGE="https://2dboy.com/"
SRC_URI="mirror://sourceforge/slackbuildsdirectlinks/worldofgoo/${MY_PN}.${PV}.tar.gz"

LICENSE="2dboy-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="bindist mirror strip"

RDEPEND="
media-libs/libsdl[opengl,sound,video]
media-libs/sdl-mixer[vorbis]
>=sys-devel/gcc-3.4
sys-libs/glibc
virtual/opengl
virtual/glu
"

dir="/opt/${PN}"
S="${WORKDIR}/${MY_PN}"
QA_PREBUILT="${dir#/}/*"

src_install() {
exeinto "${dir}"
newexe ${MY_PN%Demo}.bin$(usex amd64 64 32) ${MY_PN%Demo}.bin
make_wrapper ${PN} ./${MY_PN%Demo}.bin "${dir}"

insinto "${dir}"
doins -r icons/ properties/ res/

local icon size
for icon in icons/*.{png,svg}; do
size=${icon##*/}
size=${size%%[x.]*}
newicon -s "${size}" "${icon}" "${PN}.${icon##*.}"
done

make_desktop_entry ${PN} "World of Goo (Demo)"

dodoc linux-issues.txt
docinto html
dodoc readme.html
}

0 comments on commit 53e57f0

Please sign in to comment.