Skip to content

Commit

Permalink
media-video/raspberrypi-omxplayer: applied makefile fix from Ahmet In…
Browse files Browse the repository at this point in the history
…an <[email protected]> from bug #421683 comment gentoo#44 and gentoo#45

Package-Manager: portage-2.3.0_rc1
  • Loading branch information
fordfrog committed Jun 2, 2016
1 parent 6f6313a commit 53eace1
Show file tree
Hide file tree
Showing 3 changed files with 28 additions and 28 deletions.
26 changes: 26 additions & 0 deletions media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
--- omxplayer-9999/Makefile
+++ omxplayer-9999/Makefile
@@ -2,9 +2,11 @@

CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST

-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
+PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
+
+LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib

-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
+INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux

DIST ?= omxplayer-dist

@@ -51,8 +47,7 @@
bash gen_version.sh > version.h

omxplayer.bin: version $(OBJS)
- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvchostif -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
- $(STRIP) omxplayer.bin
+ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)

help.h: README.md Makefile
awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
26 changes: 0 additions & 26 deletions media-video/raspberrypi-omxplayer/patch

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -34,11 +34,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/popcornmix-omxplayer-${GIT_COMMIT}"

src_prepare() {
epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
epatch "${FILESDIR}"/Makefile-0_p20160528.patch \
"${FILESDIR}"/fonts-path.patch

cat > Makefile.include << EOF
LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
LIBS=-lvchostif -lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
EOF

tc-export CXX
Expand Down

0 comments on commit 53eace1

Please sign in to comment.