Skip to content

Commit

Permalink
lxqt-base/liblxqt: add version 1.1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Jimi Huotari <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
Chiitoo authored and thesamesam committed May 15, 2022
1 parent 6748746 commit 54601b4
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions lxqt-base/liblxqt/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST liblxqt-0.16.0.tar.xz 81032 BLAKE2B 4cca40db916773366187db440c85160e0064d1ed329b1f170a32c5e337e6e21b1799d1ae4d43c8c2a092abd932c1aef48e81558887dc549c5d03371e2e1ac767 SHA512 ef44d046b5c3fe40ee528a9565964814656507395585cc2df4a7debd735bcc81b6e76ed9f91fb846504104182e74b037cbea0c6beecb41ce0003f811f1dd887d
DIST liblxqt-0.17.0.tar.xz 82052 BLAKE2B a46a93b01a8df11a2158ddcd650b3bf6316447782563965ce17e3cf86f4e55443f450b3f25ce053b51a4249919d9a233f44d3c8ef4105e623d3a288ebe3c37b0 SHA512 72fd06a1bd8cee422432c3eead9ed8bf15f460848b9a3f7cdb4ee1b31c3896e6af00bc62935fe0fd7d70170010c5f128dcf9c3ecb904366818fbbfc2af3dbbf1
DIST liblxqt-1.0.0.tar.xz 82140 BLAKE2B 49dc6003207614e16c627a5b574aef9c6e42d2889eb1c0eff8da57be2476b8c1d54705ca41daa9bcd5b88f6c10153c65dc0e4f1bc10af56488152fe811913fd0 SHA512 9b0c081f644285e929f73a2a3aeb051383432ff353f918d4f8cbe57d2f5f330ab7b29329dcc17dd3605fe0904005b1c5009be77ee5ac6e2739b8baaf0fadaa5b
DIST liblxqt-1.1.0.tar.xz 82308 BLAKE2B 32f1b4625ee88fe0c0a8db640eb2eab61057d8c10ce877303f03675acd66683798f0377934b8279b824f771c28b9f3d51a5eb8ddd332b29e620f5d776950e5de SHA512 6789bc64da94d0643dfa7d234a95c533ff31123e9c7e52544d0951b309ce0e86c7323808c527f37b9dc7d06ebb35bef57a7713596d5969d2ae30ccb44cbec283
47 changes: 47 additions & 0 deletions lxqt-base/liblxqt/liblxqt-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="Common base library for the LXQt desktop environment"
HOMEPAGE="https://lxqt-project.org/"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi

LICENSE="LGPL-2.1+ BSD"
SLOT="0/$(ver_cut 1-2)"
IUSE="+backlight"

BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.11.0
"
DEPEND="
>=dev-libs/libqtxdg-3.9.0
>=dev-qt/qtcore-5.15:5
>=dev-qt/qtdbus-5.15:5
>=dev-qt/qtgui-5.15:5
>=dev-qt/qtwidgets-5.15:5
>=dev-qt/qtx11extras-5.15:5
>=dev-qt/qtxml-5.15:5
kde-frameworks/kwindowsystem:5[X]
x11-libs/libX11
x11-libs/libXScrnSaver
backlight? ( sys-auth/polkit-qt )
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
-DBUILD_BACKLIGHT_LINUX_BACKEND=$(usex backlight)
)
cmake_src_configure
}

0 comments on commit 54601b4

Please sign in to comment.