forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Parallel-Iterator: Fix tests without '.' in @inc bug #615726
- Add USE=examples - Update CPAN remote-id's Bug: https://bugs.gentoo.org/615726 Package-Manager: Portage-2.3.18, Repoman-2.3.6
- Loading branch information
1 parent
18b967d
commit 5463773
Showing
3 changed files
with
88 additions
and
0 deletions.
There are no files selected for viewing
27 changes: 27 additions & 0 deletions
27
dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=ANDYA | ||
DIST_VERSION=1.00 | ||
DIST_EXAMPLES=( "examples/*" ) | ||
inherit perl-module | ||
|
||
DESCRIPTION="Simple parallel execution" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
virtual/perl-IO | ||
virtual/perl-Storable | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-perl/Module-Build | ||
test? ( | ||
virtual/perl-Test-Simple | ||
) | ||
" | ||
PATCHES=("${FILESDIR}/${PN}-1.00-perl-5.26.patch") |
57 changes: 57 additions & 0 deletions
57
dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
From 3cf3250d8d62b93b83a34df309d1181f36a5e2ab Mon Sep 17 00:00:00 2001 | ||
From: Kent Fredric <[email protected]> | ||
Date: Sat, 23 Dec 2017 12:40:14 +1300 | ||
Subject: Fix test failures without '.' in @INC | ||
|
||
Bug: https://rt.cpan.org/Public/Bug/Display.html?id=120543 | ||
Bug: https://bugs.gentoo.org/615726 | ||
--- | ||
t/050-nofork-basic.t | 2 +- | ||
t/060-nofork-data.t | 2 +- | ||
t/070-nofork-block.t | 2 +- | ||
t/080-nofork-batch.t | 2 +- | ||
4 files changed, 4 insertions(+), 4 deletions(-) | ||
|
||
diff --git a/t/050-nofork-basic.t b/t/050-nofork-basic.t | ||
index 1409174..2d2e454 100644 | ||
--- a/t/050-nofork-basic.t | ||
+++ b/t/050-nofork-basic.t | ||
@@ -3,4 +3,4 @@ use strict; | ||
use lib 't/lib'; | ||
|
||
use NoFork; | ||
-require 't/020-data.t'; | ||
+require './t/020-data.t'; | ||
diff --git a/t/060-nofork-data.t b/t/060-nofork-data.t | ||
index 281cd07..1654671 100644 | ||
--- a/t/060-nofork-data.t | ||
+++ b/t/060-nofork-data.t | ||
@@ -3,4 +3,4 @@ use strict; | ||
use lib 't/lib'; | ||
|
||
use NoFork; | ||
-require 't/020-data.t'; | ||
+require './t/020-data.t'; | ||
diff --git a/t/070-nofork-block.t b/t/070-nofork-block.t | ||
index a3dfb52..40b7342 100644 | ||
--- a/t/070-nofork-block.t | ||
+++ b/t/070-nofork-block.t | ||
@@ -3,4 +3,4 @@ use strict; | ||
use lib 't/lib'; | ||
|
||
use NoFork; | ||
-require 't/030-block.t'; | ||
+require './t/030-block.t'; | ||
diff --git a/t/080-nofork-batch.t b/t/080-nofork-batch.t | ||
index 5d66b5c..d7c7165 100644 | ||
--- a/t/080-nofork-batch.t | ||
+++ b/t/080-nofork-batch.t | ||
@@ -3,4 +3,4 @@ use strict; | ||
use lib 't/lib'; | ||
|
||
use NoFork; | ||
-require 't/040-batch.t'; | ||
+require './t/040-batch.t'; | ||
-- | ||
2.15.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,4 +5,8 @@ | |
<email>[email protected]</email> | ||
<name>Gentoo Perl Project</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="cpan">Parallel-Iterator</remote-id> | ||
<remote-id type="cpan-module">Parallel::Iterator</remote-id> | ||
</upstream> | ||
</pkgmetadata> |