Skip to content

Commit

Permalink
media-video/mkvtoolnix: bump to 8.8.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jan 12, 2016
1 parent 9424a34 commit 549f564
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/mkvtoolnix/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mkvtoolnix-8.5.2.tar.xz 3304356 SHA256 efaae6d5e3d0963e2f53ae9c45f151be28561a6c6a28fad46e6220baf9862bbc SHA512 14a2d3d20499ccc2cfd0b1cfbbaa66def6ba512df0624f3e79d317670c4c17bf6552b9e62daed225b369fbab2fad3ce98877ccb7583096cd61da4c91ffed54ef WHIRLPOOL 536bbf36ac76e46d0205f5b2db58d986065ba38acd513129e0604154130cdf8861f3d8a52cb341980161b302f2853199c031b9908665ff13d2bb7db193a56a66
DIST mkvtoolnix-8.6.1.tar.xz 3242840 SHA256 815d8355b6a83af01c957543cee8716f1dad53e03b2ecf58b821099cd3c8fa77 SHA512 f3b14547da01a3a1268ec9b356e830391da7058741d7d8b67dcc9df5098ae9617fece67b82d6a73324f95c7060b182d94929c637baa6b9c806b2d472937151e1 WHIRLPOOL d8f4f9d3b2db77820bc018f41ac5a864057f18b22ed7711fc5c7bc3996b31041606a244b4f06b19abbaec6686990834c37ab27d5e58dd37b7c8313b24afdca51
DIST mkvtoolnix-8.7.0.tar.xz 3273484 SHA256 33502efa9a44ad561e89753d9224b7eac95b2a887812ea3d8aa2051ff3f5c15a SHA512 18e9f3d1d4c9adf2f650838e0539646e5d3efa7aa297eca50d0a6bdbca3009b617ee2c5bca203c05ba6438b06588b493b15082557826b7d1eec6a03f56544c40 WHIRLPOOL 4473bde9a606a6ee08e774cd72ba4bc4da20ecda366dfbf556366f34359005d642550d8d411b744672b144e758e9a4e1d15429551b6d16977a1675ca6fe5e57a
DIST mkvtoolnix-8.8.0.tar.xz 3544868 SHA256 912de8148d21f38c9100de61dfcac0041d1114d1a50462700b94f3bc8cd3a19c SHA512 c186c755522217a6eab282dd0e742eb263e12c181536c9bc156895c15c0a4002a9ef004ff9bd34d72c0a66f1c5785f44e688d0783f6a17db0653577b8868286c WHIRLPOOL b1a7fa19270592caccecbecd9cf2acdfb517396f855c1875dcda6289a9ac2606006357baa743ed089521a51e697301bb6f396c639e088a79f18ef7d2db3a0880
115 changes: 115 additions & 0 deletions media-video/mkvtoolnix/mkvtoolnix-8.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils multilib toolchain-funcs versionator multiprocessing autotools

DESCRIPTION="Tools to create, alter, and inspect Matroska files"
HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="curl debug pch test qt5"

ruby_atom() {
local ruby_slot=${1/ruby/}
ruby_slot="${ruby_slot:0:1}.${ruby_slot:1:2}"
echo "dev-lang/ruby:${ruby_slot}"
}

# hacks to avoid using the ruby eclasses since this requires something similar
# to the python-any-r1 eclass for ruby which currently doesn't exist
RUBY_IMPLS=( ruby22 ruby21 ruby20 )
RUBY_BDEPS="$(for ruby_impl in "${RUBY_IMPLS[@]}"; do
echo "( $(ruby_atom ${ruby_impl}) virtual/rubygems[ruby_targets_${ruby_impl}] )"; done)"

RDEPEND="
>=dev-libs/boost-1.46.0:=
>=dev-libs/libebml-1.3.3:=
dev-libs/pugixml
media-libs/flac
>=media-libs/libmatroska-1.4.4:=
media-libs/libogg
media-libs/libvorbis
sys-apps/file
sys-libs/zlib
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
)
"
DEPEND="${RDEPEND}
|| ( ${RUBY_BDEPS} )
sys-devel/gettext
virtual/pkgconfig
test? ( dev-cpp/gtest )
"

pkg_pretend() {
# https://bugs.gentoo.org/419257
local ver=4.6
local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
if ! version_is_at_least ${ver} $(gcc-version); then
eerror ${msg}
die ${msg}
fi
}

src_prepare() {
local ruby_impl
for ruby_impl in "${RUBY_IMPLS[@]}"; do
if has_version "$(ruby_atom ${ruby_impl})"; then
export RUBY=${ruby_impl}
break
fi
done
[[ -z ${RUBY} ]] && die "No available ruby implementations to build with"

epatch_user
eautoreconf
}

src_configure() {
local myconf

if use qt5 ; then
# ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
myconf+=(
--with-moc=/usr/$(get_libdir)/qt5/bin/moc
--with-uic=/usr/$(get_libdir)/qt5/bin/uic
--with-rcc=/usr/$(get_libdir)/qt5/bin/rcc
)
fi

econf \
$(use_enable debug) \
$(use_enable qt5 qt) \
$(use_with curl) \
$(usex pch "" --disable-precompiled-headers) \
"${myconf[@]}" \
--disable-optimization \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--with-boost="${EPREFIX}"/usr \
--with-boost-libdir="${EPREFIX}"/usr/$(get_libdir)
}

src_compile() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) || die
}

src_test() {
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:unit || die
"${RUBY}" ./drake V=1 -j$(makeopts_jobs) tests:run_unit || die
}

src_install() {
DESTDIR="${D}" "${RUBY}" ./drake -j$(makeopts_jobs) install || die

dodoc AUTHORS ChangeLog README.md
doman doc/man/*.1
}

0 comments on commit 549f564

Please sign in to comment.