Skip to content

Commit

Permalink
app-emulation/runc: bump to 1.0.0_rc92
Browse files Browse the repository at this point in the history
added selinux useflag (no extra deps)
removed ambient useflag (dropped upstream)
added manpage installation
bumped EAPI to 7
migrated to go-module.eclass, upstream vendors
rework installation a bit, install more docs
install bash completions

Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
gyakovlev committed Sep 22, 2020
1 parent a10a8c9 commit 55032cf
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/runc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST runc-1.0.0_rc10.tar.gz 1929802 BLAKE2B 8399c3d62726bbb6256efef7e15b7496a7172bf25170b12beb60be498967dec4fde2aebd073de4265e132ff864bafc4d2499ab677390a4f7c0a1605d83ae55e5 SHA512 598221071ef07d18bf34bf5d5c68b8ad78ee71716177fc3ce5b6909cd841d5aed93f17ebf1f3d134707d29eef1f54a4ddc21e79621a9bd957df28a8d2e028ab7
DIST runc-1.0.0_rc92.tar.gz 2061469 BLAKE2B 06444eaf7602fe9ddaf7728c7f55bd718d1fe8f5f0ce6b21abc49a1d84eaa2fc3550d0d275ba5548ee9ebb6948a8ed415de8562a990d6085d1da8fb37e46afb9 SHA512 770a31736f5ab4ba359d91bd236750511f90b29af0af2bad5c238b611f465d7302e78b57ce8a702068440fda2d74588b92fd4d24c6d34e6fc1bd649ea3d8ee40
80 changes: 80 additions & 0 deletions app-emulation/runc/runc-1.0.0_rc92.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# Change this when you update the ebuild
RUNC_COMMIT=dc9208a3303feef5b3839f4323d9beb36df0a9dd

inherit go-module linux-info

CONFIG_CHECK="~USER_NS"

MY_PV="${PV/_/-}"
SRC_URI="https://github.com/opencontainers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"

DESCRIPTION="runc container cli tools"
HOMEPAGE="http://runc.io"

LICENSE="Apache-2.0 BSD-2 BSD MIT"
SLOT="0"
IUSE="apparmor hardened +kmem +seccomp selinux test"

DEPEND="seccomp? ( sys-libs/libseccomp )"

RDEPEND="
${DEPEND}
!app-emulation/docker-runc
apparmor? ( sys-libs/libapparmor )
"

BDEPEND="
dev-go/go-md2man
test? ( "${RDEPEND}" )
"

S="${WORKDIR}/${PN}-${MY_PV}"

# tests need busybox binary, and portage namespace
# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
# majority of tests pass
RESTRICT="test"

src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
export CGO_CFLAGS="-I${ROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
-L${ROOT}/usr/$(get_libdir)"

# build up optional flags
local options=(
$(usev apparmor)
$(usev seccomp)
$(usev selinux)
$(usex kmem '' 'nokmem')
)

myemakeargs=(
BUILDTAGS="${options[*]}"
COMMIT=${RUNC_COMMIT}
DESTDIR="${ED}"
PREFIX="${ED}/usr"
)

# prevent double manpage generation
sed -i 's/^install-man: man/install-man:/' Makefile || die

emake "${myemakeargs[@]}" runc man
}

src_install() {
emake "${myemakeargs[@]}" install install-man install-bash

local DOCS=( README.md PRINCIPLES.md docs/. )
einstalldocs
}

src_test() {
emake "${myemakeargs[@]}" localunittest
}

0 comments on commit 55032cf

Please sign in to comment.