Skip to content

Commit

Permalink
app-misc/glimpse: new EAPI=6 revision with ISC license.
Browse files Browse the repository at this point in the history
Gentoo-Bug: 614676

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
orlitzky committed May 7, 2017
1 parent effb413 commit 553821f
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 8 deletions.
42 changes: 42 additions & 0 deletions app-misc/glimpse/files/glimpse-4.18.6-makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
--- a/Makefile.in 2006-03-10 20:42:12.000000000 -0500
+++ b/Makefile.in.new 2010-08-12 21:12:41.000000000 -0400
@@ -52,7 +52,7 @@
PROGAGREP = agrep/agrep
OPTIMIZEFLAGS = -O2
INCLUDEFLAGS = -I$(INDEXDIR) -I$(AGREPDIR) -I$(TEMPLATEDIR)/include
-CFLAGS = $(INCLUDEFLAGS) $(DEFS)
+CFLAGS = $(INCLUDEFLAGS) $(DEFS) $(OPTIMIZEFLAGS)

OBJS = get_filename.o \
get_index.o \
@@ -78,7 +78,7 @@
$(INDEXDIR)/memlook.c \
$(INDEXDIR)/io.c

-all: build-sub @TARGET@
+all: build-sub
Sall: $(PROG) $(PROGSERVER) $(PROGINDEX)
agrep: $(PROGAGREP)
NOTSall: $(NOTSPROG) $(NOTSPROGSERVER)
@@ -87,6 +87,7 @@
for d in $(SUBDIRS) ; do \
( cd $$d; $(MAKE) ); \
done
+ $(MAKE) @TARGET@

# Check target

@@ -105,11 +106,11 @@

install-man:
for d in $(MANUAL) ; do \
- $(INSTALL_MAN) $$d $(mandir) ; \
+ $(INSTALL_MAN) $$d $(mandir)/man1/ ; \
done

installdirs: mkinstalldirs
- $(srcdir)/mkinstalldirs $(bindir) $(mandir)
+ $(srcdir)/mkinstalldirs $(bindir) $(mandir)/man1/

clean:
for d in $(SUBDIRS); do \
Original file line number Diff line number Diff line change
@@ -1,22 +1,24 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"
EAPI=6

inherit flag-o-matic eutils
inherit flag-o-matic

DESCRIPTION="A index/query system to search a large set of files quickly"
HOMEPAGE="http://webglimpse.net/"
SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"

LICENSE="glimpse"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="static"

RDEPEND="!dev-libs/tre
!app-text/agrep"

PATCHES=( "${FILESDIR}/${PN}-4.18.6-makefile.patch" )

src_prepare() {
sed -i \
-e "s:CC=.*:CC=$(tc-getCC):" \
Expand All @@ -38,19 +40,20 @@ src_prepare() {
{agrep,compress,index}/Makefile.in \
|| die "LDFLAGS sed failed"

epatch "${FILESDIR}"/${PN}-4.18.5-makefile.patch
default
}

src_configure() {
use static && append-ldflags -static

econf || die
default
}

src_compile() {
emake OPTIMIZEFLAGS="${CFLAGS}" || die
# The OPTIMIZEFLAGS variable is our own, patched in...
emake OPTIMIZEFLAGS="${CFLAGS}"
}

src_install() {
einstall || die
# The build system is buggy; we get sandbox violations without this.
emake prefix="${ED}/usr" install
}

0 comments on commit 553821f

Please sign in to comment.