Skip to content

Commit

Permalink
dev-lang/gnu-smalltalk: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
Daniel Campbell committed Sep 12, 2016
1 parent 7a54e04 commit 5564fdd
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/gnu-smalltalk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST smalltalk-3.2.4.tar.gz 5877496 SHA256 901cc7090a1fa44bc60900a970d207de4aa3bdfdce72bea55114e243bc1eb1b3 SHA512 0854e95fb29c79a9844304651e9b2e3997ced88d7f1a704345f72aedfbae1562df0a2a2cc92ed7909e0ce22e275bb37d1592fe16079e3895cd8b79f3212cea3e WHIRLPOOL 461f07278737fbb0e5f08d18ef4f5c3678a19aef61c895e7ede7c1f74720e99bc44d347730e68a94827abfaf24c69317e2acc67ccc4bdc8cdb05ec164d5894cb
DIST smalltalk-3.2.5.tar.gz 5779293 SHA256 06e574e818ec49f0555d948ae53b1453d8c1df59ef597dad911a4fd1ffba1cce SHA512 385e5fba2acb8870759e5178282210c09c45685d0cf776bc50f4ed10c9afacf9164547ba8099ea3ed9a92a2a253aa9c2b011a7a9f2dff47ea9cfdf3b42029ebc WHIRLPOOL 3c7f1bd451eae1372d06196e1dc8408a83d8a717e67f09be4b6172d0243bca71a11d298ac9e5946a2599c6322b2ef7c204fd54d41c818151661c04af4aa89f08
80 changes: 80 additions & 0 deletions dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit elisp-common flag-o-matic eutils multilib

DESCRIPTION="GNU Smalltalk"
HOMEPAGE="http://smalltalk.gnu.org"
SRC_URI="mirror://gnu/smalltalk/smalltalk-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="tk readline emacs gtk gmp"

DEPEND="app-arch/zip
sys-libs/gdbm
sys-apps/debianutils
dev-libs/libsigsegv
virtual/libffi
emacs? ( virtual/emacs )
readline? ( sys-libs/readline )
tk? ( dev-lang/tk )
gtk? ( =x11-libs/gtk+-2* )
gmp? ( dev-libs/gmp )"
RDEPEND=""

S="${WORKDIR}/smalltalk-${PV}"

SITEFILE=50gnu-smalltalk-gentoo.el

src_prepare() {
# fix misuse of the Tcl API, bug 492710
epatch "${FILESDIR}"/${PN}-3.2_use-result.patch
}

src_configure() {
replace-flags '-O3' '-O2'
econf \
--libdir=/usr/$(get_libdir) \
--with-system-libsigsegv \
--with-system-libffi \
--with-system-libltdl \
$(use_with emacs emacs) \
$(use_with readline readline) \
$(use_with gmp gmp) \
$(use_with tk tcl /usr/$(get_libdir)) \
$(use_with tk tk /usr/$(get_libdir)) \
$(use_enable gtk gtk)
}

src_compile() {
emake || die "emake failed"
use emacs && elisp-compile *.el
}

src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
if use emacs; then
elisp-install "${PN}" *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
fperms 0444 /usr/share/smalltalk/packages.xml
# Fix QA notice complaining about dangling symlink.
# There's probably a better way to do this but I couldn't find it.
pushd "${D}"/usr/share/man/man1
rm gst-reload.1
ln -s $(find . -name "gst-load*") gst-reload.1
popd
}

pkg_postinst() {
use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 5564fdd

Please sign in to comment.