Skip to content

Commit

Permalink
sci-geosciences/qgis: 3.10.2 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 30, 2020
1 parent cc05edb commit 559dbb5
Show file tree
Hide file tree
Showing 2 changed files with 205 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-geosciences/qgis/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST qgis-3.10.1.tar.bz2 99813767 BLAKE2B 52c7708ddfb6252152ce13e19422481737b5ac20465929398d7af8997043f4fcb45f67cb2d78fa96278726c8841fc6949c25b80ffa5d1efafaa5d380bc9ace2b SHA512 0e3620d4f6aefc64c243ffd307ad5a4ed44be540d5e11f5a1cf49f046e0c7a09d3470ebb6c6efbe1481c80b3f694636044c071143daa37f3b5d8d67a273cc536
DIST qgis-3.10.2.tar.bz2 101916273 BLAKE2B 4b5d424348609e8fd1822ea9594fb11d30ae060aff15d8d962a1b15a602c1bdf5d8a17976c5a487ded5e5764e7367b8024aa52f9620ba0ec57fb075426a3c9f2 SHA512 d2ba31a8b50e0fec901d89dba6ca8467a9e26033197e78c56caaf7cce6b9bb7a1617a75f8e6275356f921ba9e986611384ab77890a4d7f5911d632e42466bb9f
DIST qgis-3.4.12.tar.bz2 74738234 BLAKE2B 7b78dfc447cafb979dd86de2fd6d6a6248ecc5de8d82285ac22d44343bc2887f97574374ff3018da4fd74ed66b7ae55e20916b9fbb3c9d8745c22f0937d6d8b6 SHA512 c932357374b2b6c71188cc53ab8606bc056fac32147d8a267024bbe6787da524ce7b18ac6a166e3d5db1d5ca9f161ff3528e3eaa951cad1f764d98fde65f02a4
DIST qgis_sample_data-2.8.14.tar.gz 22119181 BLAKE2B 2d0565e91ec8119382bc9ab8e262dc04227fe8289146794891759ff5a32012245270614ba1119a6329fc45cf56852830c2079589309aa3467873f71f5c608eac SHA512 6b2653d5b57ffc2c2317639dac212429840984ac917ca3e452b39aabb99ea106d1a77c1c1dd967244ef16ede9deae751b170affdf08b72239eafed5b8977da3d
204 changes: 204 additions & 0 deletions sci-geosciences/qgis/qgis-3.10.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,204 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
QT_MIN_VER="5.9.4"

if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN^^}.git"
inherit git-r3
else
SRC_URI="https://qgis.org/downloads/${P}.tar.bz2
examples? ( https://qgis.org/downloads/data/qgis_sample_data.tar.gz -> qgis_sample_data-2.8.14.tar.gz )"
KEYWORDS="~amd64 ~x86"
fi
inherit cmake desktop python-single-r1 qmake-utils xdg

DESCRIPTION="User friendly Geographic Information System"
HOMEPAGE="https://www.qgis.org/"

LICENSE="GPL-2+ GPL-3+"
SLOT="0"
IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar postgres python qml webkit"

REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"

BDEPEND="
${PYTHON_DEPS}
>=dev-qt/linguist-tools-${QT_MIN_VER}:5
sys-devel/bison
sys-devel/flex
"
COMMON_DEPEND="
app-crypt/qca:2[qt5(+),ssl]
>=dev-db/spatialite-4.2.0
dev-db/sqlite:3
dev-libs/expat
dev-libs/libzip:=
dev-libs/qtkeychain[qt5(+)]
>=dev-qt/designer-${QT_MIN_VER}:5
>=dev-qt/qtconcurrent-${QT_MIN_VER}:5
>=dev-qt/qtcore-${QT_MIN_VER}:5
>=dev-qt/qtgui-${QT_MIN_VER}:5
>=dev-qt/qtnetwork-${QT_MIN_VER}:5[ssl]
>=dev-qt/qtpositioning-${QT_MIN_VER}:5
>=dev-qt/qtprintsupport-${QT_MIN_VER}:5
>=dev-qt/qtserialport-${QT_MIN_VER}:5
>=dev-qt/qtsvg-${QT_MIN_VER}:5
>=dev-qt/qtsql-${QT_MIN_VER}:5
>=dev-qt/qtwidgets-${QT_MIN_VER}:5
>=dev-qt/qtxml-${QT_MIN_VER}:5
media-gfx/exiv2:=
>=sci-libs/gdal-2.2.3:=[geos]
sci-libs/geos
sci-libs/libspatialindex:=
>=sci-libs/proj-4.9.3:=
>=x11-libs/qscintilla-2.10.1:=[qt5(+)]
>=x11-libs/qwt-6.1.2:6=[qt5(+),svg]
3d? ( >=dev-qt/qt3d-${QT_MIN_VER}:5 )
georeferencer? ( sci-libs/gsl:= )
grass? ( =sci-geosciences/grass-7*:= )
hdf5? ( sci-libs/hdf5:= )
mapserver? ( dev-libs/fcgi )
netcdf? ( sci-libs/netcdf:= )
opencl? ( virtual/opencl )
oracle? (
dev-db/oracle-instantclient:=
sci-libs/gdal:=[oracle]
)
polar? ( >=x11-libs/qwtpolar-1.1.1-r1[qt5(+)] )
postgres? ( dev-db/postgresql:= )
python? (
${PYTHON_DEPS}
dev-python/future[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]
dev-python/owslib[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[designer,network,sql,svg,webkit?,${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/sip:=[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
)
qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
"
DEPEND="${COMMON_DEPEND}
>=dev-qt/qttest-${QT_MIN_VER}:5
python? ( ${PYTHON_DEPS} )
"
RDEPEND="${COMMON_DEPEND}
sci-geosciences/gpsbabel
"

# Disabling test suite because upstream disallow running from install path
RESTRICT="test"

PATCHES=(
# git master
"${FILESDIR}/${PN}-3.10.0-cmake-lib-suffix.patch"
# TODO upstream
"${FILESDIR}/${PN}-3.4.7-featuresummary.patch"
"${FILESDIR}/${PN}-3.4.7-default-qmldir.patch"
)

pkg_setup() {
python-single-r1_pkg_setup
}

src_prepare() {
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DQGIS_MANUAL_SUBDIR=share/man/
-DQGIS_LIB_SUBDIR=$(get_libdir)
-DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis
-DQWT_INCLUDE_DIR=/usr/include/qwt6
-DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt5.so
-DPEDANTIC=OFF
-DUSE_CCACHE=OFF
-DWITH_ANALYSIS=ON
-DWITH_APIDOC=OFF
-DWITH_GUI=ON
-DWITH_INTERNAL_MDAL=ON # not packaged, bug 684538
-DWITH_QSPATIALITE=ON
-DENABLE_TESTS=OFF
-DWITH_3D=$(usex 3d)
-DWITH_GEOREFERENCER=$(usex georeferencer)
-DWITH_GRASS7=$(usex grass)
$(cmake_use_find_package hdf5 HDF5)
-DWITH_SERVER=$(usex mapserver)
$(cmake_use_find_package netcdf NetCDF)
-DUSE_OPENCL=$(usex opencl)
-DWITH_ORACLE=$(usex oracle)
-DWITH_QWTPOLAR=$(usex polar)
-DWITH_POSTGRESQL=$(usex postgres)
-DWITH_BINDINGS=$(usex python)
-DWITH_CUSTOM_WIDGETS=$(usex python)
-DWITH_QUICK=$(usex qml)
-DWITH_QTWEBKIT=$(usex webkit)
)

if use grass; then
mycmakeargs+=(
-DGRASS_PREFIX7=/usr/$(get_libdir)/grass70
)
fi

use python && mycmakeargs+=( -DBINDINGS_GLOBAL_INSTALL=ON )

# bugs 612956, 648726
addpredict /dev/dri/renderD128
addpredict /dev/dri/renderD129

cmake_src_configure
}

src_install() {
cmake_src_install

insinto /usr/share/mime/packages
doins debian/qgis.xml

if use examples; then
docinto examples
dodoc -r "${WORKDIR}"/qgis_sample_data/.
docompress -x /usr/share/doc/${PF}/examples
fi

if use python; then
python_optimize
python_optimize "${ED}"/usr/share/qgis/python
fi

if use grass; then
python_fix_shebang "${ED}"/usr/share/qgis/grass/scripts
fi
}

pkg_postinst() {
if use postgres; then
elog "If you don't intend to use an external PostGIS server"
elog "you should install:"
elog " dev-db/postgis"
elif use python; then
elog "Support of PostgreSQL is disabled."
elog "But some installed python-plugins import the psycopg2 module."
elog "If you do not need these plugins just disable them"
elog "in the Plugins menu, else you need to set USE=\"postgres\""
fi

xdg_pkg_postinst
}

0 comments on commit 559dbb5

Please sign in to comment.