Skip to content

Commit

Permalink
mail-client/neomutt: Version bump to 20211029
Browse files Browse the repository at this point in the history
Signed-off-by: Nicolas Bock <[email protected]>
  • Loading branch information
nicolasbock committed Oct 29, 2021
1 parent f3cf558 commit 55e57d3
Show file tree
Hide file tree
Showing 2 changed files with 163 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/neomutt/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST neomutt-20210205.tar.gz 3476980 BLAKE2B 2b8f07a957d668f0903ae3f48d72e0b00414b9ed0411723bc725cd2369ed16c31e461799a0161f3b6caecb8b3a182a0ad9ca7bbb5431ed9ff67cae5dc87b11e5 SHA512 4e9faaa989eb17d1f65e835d3ad37bbda3307f9a939f351776d4cb4677d856fa998ba0eff04bf0cf344485977077695e07c55e79e0800888f646c46fbfac8554
DIST neomutt-20211015.tar.gz 3727778 BLAKE2B 2a2c57014b089a86ee38a261251ef1ee8c07d25753358cde4f3be0897a04f1fa54828e7cbe7435d004adc49afa40bcfd80ad7e9a8f4c4e7b11ebd7d7f7f60a2a SHA512 b466fa73567b3f97c084133315dc8b35578ca369018a7beccb0e6f18324add262c591671c4fc60defd3c9623db7e95e2f631a6df10b0ef3869cf0e4a6b0eec03
DIST neomutt-20211022.tar.gz 3731092 BLAKE2B 764b82e1fffda57949b063b2c7b9a0c747c2769cc546ff04e56d8f9d91e689be72fd9a7e05a772162b9fae3683dd72631982056ca12c8d4a061efeb8013ac55e SHA512 8e574cd9bed19880eeb1605bb8fac1e5933571c2b499364465efce4212e2bcd7c6bc9909bf8241b5dd0fa461a55f71fdd04f4b35fc1d92ffea4647ac2b3672d0
DIST neomutt-20211029.tar.gz 3702926 BLAKE2B 28868799da89d0acfe75b07b6716b25cd827a187711ed011a46b90135358521eccf4a6cd8938983342d4cdd04ffc951cdbf4531f9f48e2209e58e8133932df3a SHA512 7335a4451aa8657aa83988b42fb78c5ebdc82ce4395d93d1eb2fded36b02d3fac9b8fed3cf1353042ecebe11e6ccdd9d403b99f068555693901b1700791e3ae0
DIST neomutt-test-files-8629adab700a75c54e8e28bf05ad092503a98f75.tar.gz 3673 BLAKE2B 50354f19aedc5fc07d59ecb5b38fa65de16119bc0929f47014bd35dab4d3a4e5953c8b35670f3440003cf0cbccc2d0d2b3a869dc929cdc3cd60b02790270fb54 SHA512 3d4962210bc558234d818801dcaa7851a0aef011c96d91c054af535186ffda42059fc61fb148c48e1b076999fe3159b31589a69a29ed1897f8928f52fcc157d3
162 changes: 162 additions & 0 deletions mail-client/neomutt/neomutt-20211029.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,162 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

if [[ ${PV} =~ 99999999$ ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~ppc64 ~s390 ~x86"
fi

TEST_FILES_COMMIT=8629adab700a75c54e8e28bf05ad092503a98f75
SRC_URI+=" test? ( https://github.com/${PN}/neomutt-test-files/archive/${TEST_FILES_COMMIT}.tar.gz -> neomutt-test-files-${TEST_FILES_COMMIT}.tar.gz )"

DESCRIPTION="A small but very powerful text-based mail client"
HOMEPAGE="https://neomutt.org/"

LICENSE="GPL-2"
SLOT="0"
IUSE="autocrypt berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet
lmdb lz4 nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
ssl tokyocabinet test zlib zstd"
REQUIRED_USE="
autocrypt? ( gpgme )"

CDEPEND="
app-misc/mime-types
berkdb? (
|| (
sys-libs/db:6.2
sys-libs/db:5.3
sys-libs/db:4.8
)
<sys-libs/db-6.3:=
)
gdbm? ( sys-libs/gdbm:= )
kyotocabinet? ( dev-db/kyotocabinet )
lmdb? ( dev-db/lmdb:= )
nls? ( virtual/libintl )
qdbm? ( dev-db/qdbm )
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17:= )
gpgme? ( >=app-crypt/gpgme-1.13.1:= )
autocrypt? ( >=dev-db/sqlite-3 )
idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
notmuch? ( net-mail/notmuch:= )
sasl? ( >=dev-libs/cyrus-sasl-2 )
!slang? ( sys-libs/ncurses:0= )
slang? ( sys-libs/slang )
ssl? ( >=dev-libs/openssl-1.0.2u:0= )
lz4? ( app-arch/lz4 )
zlib? ( sys-libs/zlib )
zstd? ( app-arch/zstd )
"
DEPEND="${CDEPEND}
dev-lang/tcl:=
net-mail/mailbase
doc? (
dev-libs/libxml2
dev-libs/libxslt
app-text/docbook-xsl-stylesheets
|| (
www-client/lynx
www-client/w3m
www-client/elinks
)
)
"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-mutt )
"

RESTRICT="!test? ( test )"

src_configure() {
local myconf=(
"$(usex doc --full-doc --disable-doc)"
"$(use_enable nls)"
"$(use_enable notmuch)"

"$(use_enable autocrypt)"
"$(use_enable gpgme)"
"$(use_enable pgp-classic pgp)"
"$(use_enable smime-classic smime)"

# Database backends.
"$(use_enable berkdb bdb)"
"$(use_enable gdbm)"
"$(use_enable kyotocabinet)"
"$(use_enable qdbm)"
"$(use_enable tokyocabinet)"

# Header compression.
"$(use_enable lz4)"
"$(use_enable zlib)"
"$(use_enable zstd)"

"$(use_enable idn)"
"$(use_enable kerberos gss)"
"$(use_enable lmdb)"
"$(use_enable sasl)"
"--with-ui=$(usex slang slang ncurses)"
"--sysconfdir=${EPREFIX}/etc/${PN}"
"$(use_enable ssl)"
"$(use_enable gnutls)"

"$(usex test --testing --disable-testing)"
)

econf CCACHE=none CC_FOR_BUILD=$(tc-getCC) "${myconf[@]}"
}

src_test() {
local test_dir="$(readlink --canonicalize ${S}/../neomutt-test-files-${TEST_FILES_COMMIT})"
pushd ${test_dir} || die "Could not cd into test_dir"
NEOMUTT_TEST_DIR="${test_dir}" ./setup.sh \
|| die "Failed to run the setup.sh script"
popd || die "Could not cd back"
NEOMUTT_TEST_DIR="${test_dir}" emake test
}

src_install() {
emake DESTDIR="${D}" install

# A man-page is always handy, so fake one - here neomuttrc.5 (neomutt.1
# already exists)
if use !doc; then
sed -n \
-e '/^\(CC_FOR_BUILD\|CFLAGS_FOR_BUILD\)\s*=/p' \
-e '/^\(EXTRA_CFLAGS_FOR_BUILD\|LDFLAGS_FOR_BUILD\)\s*=/p' \
-e '/^\(EXEEXT\|SRCDIR\)\s*=/p' \
Makefile > docs/Makefile.fakedoc || die
sed -n \
-e '/^MAKEDOC_CPP\s*=/,/^\s*$/p' \
-e '/^docs\/\(makedoc$(EXEEXT)\|neomutt\.1\|neomuttrc\.5\)\s*:/,/^\s*$/p' \
docs/Makefile.autosetup >> docs/Makefile.fakedoc || die
emake -f docs/Makefile.fakedoc docs/neomutt.1
emake -f docs/Makefile.fakedoc docs/neomuttrc.5
doman docs/neomutt.1 docs/neomuttrc.5
fi

dodoc LICENSE* ChangeLog* README*
}

pkg_postinst() {
if use gpgme && ( use pgp-classic || use smime-classic ); then
ewarn " Note that gpgme (old gpg) includes both pgp and smime"
ewarn " support. You can probably remove pgp-classic (old crypt)"
ewarn " and smime-classic (old smime) from your USE-flags and"
ewarn " only enable gpgme."
fi

if use autocrypt && ! use idn; then
ewarn " It is highly recommended that NeoMutt be also configured"
ewarn " with idn when autocrypt is enabled."
fi
}

0 comments on commit 55e57d3

Please sign in to comment.