Skip to content

Commit

Permalink
dev-python/mypy: add version 0.4.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
Alex Brandt committed Jun 18, 2016
1 parent 6f8f8be commit 563b8e3
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/mypy/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mypy-0.2.0.tar.gz 626604 SHA256 0c24f50509bdf3e0d9bd386a08ef4f11ee0114e1f5a9b2afeacbf9561cf022c1 SHA512 b03014abf152407c7629dba925aca6178fcdf57532f47c728edcb591a56942cda13e02122f405aa269e9b6303de1f4a9d5cbb2d5a5af6e90a808a3db94cca53f WHIRLPOOL 7d9f05ead0bfea78bdf228b0bb7c3519e8eaa70f52c00049963780f42e71e9f44168edb09d2e558f59b07a4d09912d1d6d3c8b11a2b9e47db77b2c06e56eb910
DIST mypy-0.4.1.tar.gz 682081 SHA256 37e94e528078fff782bfbe36c0e9cbd2ff40aa436eb335c2c75d006136aee3e7 SHA512 fafe93ba5e5989be5ebe966c9b8ca3ff899101b56407d5167ef42173374aae5f8ebf5631e573b5d45b845fe2b17488834c72e2483e68abf4992a39188ffa50a1 WHIRLPOOL 5b2f2d5d6fe00ccad93824476e55f673c9ecc8bc38b0aa2f3ce2f25850a9dca17b8bb91ad537801a6ecc0bc2ac0210282bcbd755e6c0a96cd9f8b647530cc093
DIST mypy-0.4.2.tar.gz 697919 SHA256 d39607701c226007f3bb5a7619222c6c6e7e4c4a2c565d99d44377324d2072ad SHA512 16d2f1476bc7b40c20b66aca81b3c99477394cbcbbff5541ca26179bde0634794126c0b28506ad3019d6a1c5cd0bf48292b4de0152927123ffdfb3bbbc69ee15 WHIRLPOOL 45e459ac076e5bb800a3b8f62828fb326a43d69522caf493166694e4a11b65136756dde43f01e13ac4c74a0535595914364096042dad40c631f17837ca1aca0b
43 changes: 43 additions & 0 deletions dev-python/mypy/mypy-0.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python3_3 python3_4 python3_5 )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="Optional static typing for Python"
HOMEPAGE="http://www.mypy-lang.org/"
SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples test"

DEPEND="
test? ( dev-python/flake8[${PYTHON_USEDEP}] )
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
"
RDEPEND="$(python_gen_cond_dep '!dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
local PYTHONPATH="$(pwd)"

"${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/build/html/. )
use examples && local EXAMPLES=( samples/. )

distutils-r1_python_install_all
}

0 comments on commit 563b8e3

Please sign in to comment.