Skip to content

Commit

Permalink
app-arch/dtrx: bump to 8.5.3
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed May 15, 2023
1 parent ebc63d5 commit 563e263
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/dtrx/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dtrx-8.5.0.tar.gz 34061 BLAKE2B d8ecbd9f3594440656e40d811846dd302d271f189711176a406572871db69f98bb4fd81a76ebdce697faf8d56029f4dcf735d18795adf732809e6017a7395cf2 SHA512 0ef0c0c9c22d948f6a8ee801372605dae52f4f571a32bbaa180c2c1daab061d623119c91b745f6a86cd28d7d08cdb47029a4de38354bdb28c62acfab080cc0f1
DIST dtrx-8.5.2.tar.gz 34112 BLAKE2B 01d13bc2f53bb8093c8c69acea6af4d80ef3c58dc61ad28a79b1385814693738c371bb38742aa6df933c8f69d1ad86ba05c45d222e4b5398df8fc811c50c2c9e SHA512 b8091bc0a948b9fd796b9a6e335e270736e9a66d103406bbac7d5064cf01067daed5f4287ab5e29aca61819915461ff31979dda437fd6089ab3f62c44d97f065
DIST dtrx-8.5.3.tar.gz 34147 BLAKE2B 156d2305f777b63870490736fd769a9d480f390d41ac0aa6acac16d4c5b21bb5b3f88d7b2cea6ecbf74511895bb3c3d923a6186d5189ebf3f7a5f4bb5db6c0f1 SHA512 0c29f0d9ca03d11206297669c20c3443c420db4aa0d91da54a5f6ac7236120af04a1a8d7e2e4f85b3d7e6c6050786cc0293bab02f424fe3be52a40f069d397be
57 changes: 57 additions & 0 deletions app-arch/dtrx/dtrx-8.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit distutils-r1 optfeature

DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
HOMEPAGE="https://github.com/dtrx-py/dtrx/
https://pypi.org/project/dtrx/"

if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
else
inherit pypi
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi

LICENSE="GPL-3+"
SLOT="0"

DOCS=( README.md )

src_prepare() {
sed -i '/ *platform==/s|.*||' setup.cfg || die # bug #894148

distutils-r1_src_prepare
}

pkg_postinst() {
local supported_format
local -a supported_formats=(
arj
bzip2
cpio
gzip
lrzip
lzip
p7zip
rpm
unrar
unzip
xz-utils
zip
zstd
)

for supported_format in ${supported_formats[@]}; do
optfeature \
"extraction of supported archives using ${supported_format}" \
app-arch/${supported_format}
done
}

0 comments on commit 563e263

Please sign in to comment.