forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/keepassxc: Initial commit (bug #598601).
Thanks to Igor Krivenko for providing the initial ebuild. Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Lars Wendler
committed
Feb 10, 2017
1 parent
debe0de
commit 565861f
Showing
4 changed files
with
151 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST keepassxc-2.1.1.tar.gz 3274143 SHA256 b0a737640070d80483b2ac436d87c2872a248f60f86b741e5413b0b8cda92eef SHA512 7ec2aab5b5e87036b3c778fd9b24612a35ac80243c009da9151f0a8aca9b7065c6652bc595be2958cd4fd96c5c8937cc7ce668c47d34267b7e014c3117a32e72 WHIRLPOOL 5cb6a85c58e28eeff8f11bb70a8b949e15e0f97769c73844474abab321c40f81c6a23b3efe1c05ce5e8e8623c7feb3e38d64cda88b13fedc651a722a3607806f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
SCM="" | ||
[[ "${PV}" == 9999 ]] && SCM="git-r3" | ||
inherit cmake-utils ${SCM} | ||
unset SCM | ||
|
||
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition" | ||
HOMEPAGE="https://github.com/keepassxreboot/keepassxc" | ||
|
||
if [[ "${PV}" != 9999 ]] ; then | ||
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
else | ||
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}" | ||
fi | ||
|
||
LICENSE="LGPL-2.1 GPL-2 GPL-3" | ||
SLOT="0" | ||
IUSE="autotype debug http test" | ||
|
||
RDEPEND=" | ||
dev-libs/libgcrypt:= | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtwidgets:5 | ||
net-libs/libmicrohttpd | ||
sys-libs/zlib | ||
autotype? ( | ||
dev-qt/qtx11extras:5 | ||
x11-libs/libXi | ||
x11-libs/libXtst | ||
) | ||
" | ||
#yubikey? ( sys-auth/libyubikey ) | ||
|
||
DEPEND=" | ||
${RDEPEND} | ||
dev-qt/linguist-tools:5 | ||
dev-qt/qtconcurrent:5 | ||
test? ( dev-qt/qttest:5 ) | ||
" | ||
|
||
src_prepare() { | ||
use test || \ | ||
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_GUI_TESTS=OFF | ||
-DWITH_TESTS="$(usex test)" | ||
-DWITH_XC_AUTOTYPE="$(usex autotype)" | ||
-DWITH_XC_HTTP="$(usex http)" | ||
#-DWITH_XC_YUBIKEY="$(usex yubikey)" | ||
) | ||
cmake-utils_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
SCM="" | ||
[[ "${PV}" == 9999 ]] && SCM="git-r3" | ||
inherit cmake-utils ${SCM} | ||
unset SCM | ||
|
||
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition" | ||
HOMEPAGE="https://github.com/keepassxreboot/keepassxc" | ||
|
||
if [[ "${PV}" != 9999 ]] ; then | ||
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
else | ||
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}" | ||
fi | ||
|
||
LICENSE="LGPL-2.1 GPL-2 GPL-3" | ||
SLOT="0" | ||
IUSE="autotype debug http test" | ||
|
||
RDEPEND=" | ||
dev-libs/libgcrypt:= | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtwidgets:5 | ||
net-libs/libmicrohttpd | ||
sys-libs/zlib | ||
autotype? ( | ||
dev-qt/qtx11extras:5 | ||
x11-libs/libXi | ||
x11-libs/libXtst | ||
) | ||
" | ||
# yubikey? ( sys-auth/libyubikey ) | ||
|
||
DEPEND=" | ||
${RDEPEND} | ||
dev-qt/linguist-tools:5 | ||
dev-qt/qtconcurrent:5 | ||
test? ( dev-qt/qttest:5 ) | ||
" | ||
|
||
src_prepare() { | ||
use test || \ | ||
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_GUI_TESTS=OFF | ||
-DWITH_TESTS="$(usex test)" | ||
-DWITH_XC_AUTOTYPE="$(usex autotype)" | ||
-DWITH_XC_HTTP="$(usex http)" | ||
#-DWITH_XC_YUBIKEY="$(usex yubikey)" | ||
) | ||
cmake-utils_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Lars Wendler</name> | ||
</maintainer> | ||
<use> | ||
<flag name="autotype">Add support to autotype the passwords into other applications</flag> | ||
<flag name="http">Add http support</flag> | ||
</use> | ||
<longdescription> | ||
KeePassXC provides a safe location for your passwords and similar | ||
data. It encrypts its databasee with AES either by passphrase or a key | ||
file, compatible with a PDA and Windows version. | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="github">keepassxreboot/keepassxc</remote-id> | ||
</upstream> | ||
</pkgmetadata> |