Skip to content

Commit

Permalink
dev-ruby/travis: add 1.11.0
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Apr 17, 2022
1 parent dd5645e commit 565aab3
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/travis/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST travis-1.10.0.gem 197632 BLAKE2B 0639f797789d1676f71b6354ed77e3e403865cca37e5e04c62e4cfd40d44e26e8e93ea0dbf39843811cccb7960e43b186d61d64f681d2eafe95de890d9fd66a7 SHA512 025e8cdf48100ff20d85925a6285993bda0d1651e145d554c2ec987c4557e2d3bc49da6529af4c577fcd9b88600549b3c12cff49b824d7fcb93a96a0c572603c
DIST travis-1.11.0.gem 196096 BLAKE2B 2ea09d88fd45d6fd304746a96cc063c0525c8af8df6be2a0ba5c7ad06909055af23ea506f89f246f657c5a8920c429dd3aebc639f78cd1d0acb5bb03e4894434 SHA512 b6db17b149a54f7ab3c5b79439b1385386bbfe0350816d303e7c74c0494be08451fdb14550cba7fb54df3a643a530f1434bb1ee0c3e28c492ac6e8f3baf3d558
56 changes: 56 additions & 0 deletions dev-ruby/travis/travis-1.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRAINSTALL="assets"

inherit bash-completion-r1 ruby-fakegem

DESCRIPTION="Travis CI Client (CLI and Ruby library)"
HOMEPAGE="https://github.com/travis-ci/travis.rb"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
#RESTRICT="test"

DEPEND+="test? ( dev-vcs/git )"
RDEPEND+="dev-vcs/git"

ruby_add_bdepend "
test? ( >dev-ruby/rack-test-0.6 dev-ruby/rspec-its )
>dev-ruby/sinatra-1.3
"

ruby_add_rdepend "
dev-ruby/faraday:1
dev-ruby/faraday_middleware:1
>=dev-ruby/gh-0.17
dev-ruby/highline:2
>=dev-ruby/json-2.3:2
>=dev-ruby/launchy-2.1
>dev-ruby/pusher-client-0.4
"

all_ruby_prepare() {
if use test ; then
git init --quiet . || die
git remote add origin "${HOMEPAGE}" || die
touch .travis.yml || die
fi

# Remove failing specs where $params keys are reset somewhere.
rm -f spec/cli/{cancel,restart}_spec.rb || die

sed -i -e 's/json_pure/json/' ../metadata || die
}

all_ruby_install() {
all_fakegem_install

newbashcomp "assets/travis.sh" "travis"
}

0 comments on commit 565aab3

Please sign in to comment.