Skip to content

Commit

Permalink
dev-libs/re2: bump to 0.2016.11.01
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3_p9, Repoman-2.3.1_p2
  • Loading branch information
floppym committed Dec 26, 2016
1 parent 3346f9e commit 566ef37
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/re2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST re2-2016-05-01.tar.gz 399509 SHA256 d9d13f0ea4e1c6628b1cb85eeee284d4fdd4948da94b1f205096254927092e3d SHA512 6d37ab1eae51a73f60d3c8280ea1162c420638363f0eb1313d7c2d5cee65a5abd4c2927da1a53572afbcb7d07fac2993a7e54c6cbc85e24aaae93c46dab19b14 WHIRLPOOL b601349800341d213b01219cf2171873be551488c71c2c06fbab1da27c20719fca12e0cfac30ac4e8ed0eb062a445b4c008491fd0e379f629434e0c9b4649a7e
DIST re2-2016-11-01.tar.gz 379816 SHA256 01ee949f03e1c4057dc533cf139f967fb1b427015769d53b9ee07757631e9669 SHA512 1be7d2551737cb9dc1031dac9335f82dfb58f3612bdb745bf6c5121334bf8689bb0564b751c23e4c002478cc46cc237ce4da294090adb983b0c1db25a9fac0a7 WHIRLPOOL 447b1ddb74826f3e73fe895690eac4f482096e05b88fbe3a143db0e2275031db6fa0cb2105ac09ab4b250db2bdef7097a75e3b4c8a04f23aa936009ea2f27439
47 changes: 47 additions & 0 deletions dev-libs/re2/re2-0.2016.11.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit multilib-minimal toolchain-funcs

# Different date format used upstream.
RE2_VER=${PV#0.}
RE2_VER=${RE2_VER//./-}

DESCRIPTION="An efficent, principled regular expression library"
HOMEPAGE="https://github.com/google/re2"
SRC_URI="https://github.com/google/re2/archive/${RE2_VER}.tar.gz -> re2-${RE2_VER}.tar.gz"

LICENSE="BSD"
# NOTE: Always run libre2 through abi-compliance-checker!
# https://abi-laboratory.pro/tracker/timeline/re2/
SLOT="0/0.2016.11.01"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="icu"

RDEPEND="icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
icu? ( virtual/pkgconfig )"

S="${WORKDIR}/re2-${RE2_VER}"

DOCS=( AUTHORS CONTRIBUTORS README doc/syntax.txt )
HTML_DOCS=( doc/syntax.html )

src_prepare() {
default
if use icu; then
sed -i -e 's:^# \(\(CC\|LD\)ICU=.*\):\1:' Makefile || die
fi
multilib_copy_sources
}

src_configure() {
tc-export AR CXX NM
}

multilib_src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="\$(exec_prefix)/$(get_libdir)" install
}

0 comments on commit 566ef37

Please sign in to comment.