Skip to content

Commit

Permalink
net-analyzer/ifstatus: Fixed compilation with gcc-6 (bug #594510).
Browse files Browse the repository at this point in the history
Thanks to Peter Levine for providing the patch.
Also bumped ebuild to EAPI-6.

Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed May 6, 2017
1 parent 3c7bd6c commit 56cb960
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 5 deletions.
12 changes: 12 additions & 0 deletions net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- ifstatus/Interface.h.old 2016-09-27 03:52:02.063811332 -0400
+++ ifstatus/Interface.h 2016-09-27 03:53:33.305880857 -0400
@@ -57,7 +57,8 @@

InterfaceData & operator=(InterfaceData & rInterfaceData);
InterfaceData operator-(InterfaceData & rInterfaceData);
-
+ InterfaceData & operator=(InterfaceData && rInterfaceData) = default;
+ InterfaceData(const InterfaceData&) = default;
private:

unsigned long long m_ullReceived[eTotalTypes];
15 changes: 10 additions & 5 deletions net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=6
inherit eutils toolchain-funcs

KEYWORDS="amd64 arm ~ppc x86"
Expand All @@ -12,17 +12,22 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"

RDEPEND=">=sys-libs/ncurses-4.2"
RDEPEND=">=sys-libs/ncurses-4.2:0="
DEPEND="
${RDEPEND}
virtual/pkgconfig
"

S="${WORKDIR}/${PN}"

PATCHES=(
"${FILESDIR}/${P}-gcc43.patch"
"${FILESDIR}/${P}-tinfo.patch"
"${FILESDIR}/${P}-gcc6.patch"
)

src_prepare() {
epatch "${FILESDIR}/${P}-gcc43.patch"
epatch "${FILESDIR}/${P}-tinfo.patch"
default
tc-export CXX PKG_CONFIG
}

Expand Down

0 comments on commit 56cb960

Please sign in to comment.