forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-pop-shell: add 1.2.0_p20231110
Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
62 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gnome-shell-extension-pop-shell-1.2.0_p20220928.tar.gz 862942 BLAKE2B f692184bfb19571322fc8c8364182e69a2ac3f21b8f3657362ec387539659f7109413e9459ef5766ac7fc334ee56cee49c588d18a3e9701cc104beefb6eb0c4f SHA512 aecf8b8e3089bc1e1cc62ca0095705223dc3fcb7f30eab39166d39678037ca81076cf46960a27cfcb245bc540fe26ba0b3332747b9a41ad63e4f0ed50b8cf609 | ||
DIST gnome-shell-extension-pop-shell-1.2.0_p20230626.tar.gz 864018 BLAKE2B 474dde2a131e53a52c8f8c648f6ec2a438e383485a675a625e7d20b3021e5955aa0bbfaa5f344881f754d486e1f601c3cf54adcd8839e76d77029767f8b01e64 SHA512 01aa86d3d78cc24dd8fc1b4f0834739f2974a0c82c875a039520dd1f4676afc7ff69c40927beb300d698834116d0d76fc45db3c8a81833628b4c2144f9052011 | ||
DIST gnome-shell-extension-pop-shell-1.2.0_p20231110.tar.gz 864255 BLAKE2B 3398216664b53315aac84f9d77eb471dfe2b8f3db09c43f5d1ff3d20793c19cf62a6a3459873a76f5a45386f5b5a98933ea242a20d7eff5444a84db5b157ae14 SHA512 bda3f358a2c3e866875dbd5142564754ea2d55fe2bb95120e6a3d4ef04c56fd29688da415404edc3ca73fa16927ff33377c3aea19e0afd46da30342584e77199 |
61 changes: 61 additions & 0 deletions
61
...ra/gnome-shell-extension-pop-shell/gnome-shell-extension-pop-shell-1.2.0_p20231110.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
# Copyright 2021-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
inherit gnome2-utils optfeature readme.gentoo-r1 | ||
|
||
EGIT_COMMIT="aafc9458a47a68c396933c637de00421f5198a2a" | ||
|
||
DESCRIPTION="Keyboard-driven layer for GNOME Shell with tiling support" | ||
HOMEPAGE="https://github.com/pop-os/shell" | ||
SRC_URI="https://github.com/pop-os/shell/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=gnome-base/gnome-shell-45 | ||
sys-apps/fd | ||
" | ||
BDEPEND="dev-lang/typescript" | ||
|
||
S="${WORKDIR}/shell-${EGIT_COMMIT}" | ||
|
||
DOC_CONTENTS="To configure keybindings run /usr/lib/pop-shell/scripts/configure.sh as user" | ||
|
||
src_install() { | ||
default | ||
|
||
insinto /usr/share/glib-2.0/schemas | ||
doins schemas/org.gnome.shell.extensions.pop-shell.gschema.xml | ||
|
||
exeinto /usr/lib/pop-shell/scripts | ||
doexe scripts/configure.sh | ||
|
||
insinto /usr/share/gnome-control-center/keybindings | ||
doins keybindings/*.xml | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
|
||
gnome2_schemas_update | ||
|
||
readme.gentoo_print_elog | ||
optfeature "better tiling via native-window-placement" gnome-extra/gnome-shell-extensions | ||
} | ||
|
||
pkg_postrm() { | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
|
||
gnome2_schemas_update | ||
} |