Skip to content

Commit

Permalink
dev-util/dwdiff: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
monsieurp committed Mar 21, 2016
1 parent f74e6f4 commit 573f828
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils toolchain-funcs

DESCRIPTION="diff-like program that operates at the word level instead of the line level"
HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
SRC_URI="http://os.ghalkes.nl/dist/${P}.tar.bz2"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="nls"

CDEPEND="dev-libs/icu:="

RDEPEND="
${CDEPEND}
sys-apps/diffutils"

DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )"

src_prepare() {
default

sed -i \
-e '/INSTALL/s:COPYING::' \
Makefile.in || die
}

src_configure() {
./configure \
--prefix=/usr \
$(use_with nls gettext)
}

src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}

src_install() {
emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
}

0 comments on commit 573f828

Please sign in to comment.