Skip to content

Commit

Permalink
dev-python/jibx-tools: Removes java-virtual/stax-api dependency and f…
Browse files Browse the repository at this point in the history
…ixes bug 561504.

Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Sep 28, 2015
1 parent bd120b0 commit 57f0489
Showing 1 changed file with 52 additions and 0 deletions.
52 changes: 52 additions & 0 deletions dev-java/jibx-tools/jibx-tools-1.1.5-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
JAVA_PKG_IUSE="source"

inherit java-pkg-2 java-ant-2 versionator

MY_PV=$(replace_all_version_separators '_')

DESCRIPTION="JiBX: Binding XML to Java Code - Generators"
HOMEPAGE="http://jibx.sourceforge.net/"
SRC_URI="mirror://sourceforge/jibx/jibx_${MY_PV}.zip"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

CDEPEND="dev-java/bcel:0
dev-java/jibx:0"

RDEPEND=">=virtual/jre-1.6
${CDEPEND}"

DEPEND=">=virtual/jdk-1.6
app-arch/unzip
${CDEPEND}"

S="${WORKDIR}/jibx"

java_prepare() {
# http://jira.codehaus.org/browse/JIBX-207
epatch "${FILESDIR}/1.1.5-build.patch"

java-ant_rewrite-classpath "${S}/build/build.xml"

rm -v "${S}"/lib/*.jar || die
}

EANT_FILTER_COMPILER="ecj-3.3"
EANT_BUILD_XML="build/build.xml"
EANT_BUILD_TARGET="jar-tools"
EANT_GENTOO_CLASSPATH="bcel,jibx"

src_install() {
java-pkg_register-dependency jibx

java-pkg_dojar "${S}/lib"/jibx-*.jar
use source && java-pkg_dosrc "${S}"/build/src/* "${S}"/build/extras/*
}

0 comments on commit 57f0489

Please sign in to comment.