Skip to content

Commit

Permalink
kde-misc/tellico: 3.3 version bump
Browse files Browse the repository at this point in the history
See also: https://tellico-project.org/tellico-3-3-released/

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Apr 24, 2020
1 parent f646e1f commit 58107f5
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-misc/tellico/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tellico-3.2.3.tar.xz 5589552 BLAKE2B e22f0344ccd879694976bc00fa6bcb52e3b878d4ef92c05b9b9a62ab74b1e84cd4b649682a55ee4a1b2da4678676abe8f1da5591f57dbd7db156b5e5bd0b9dd1 SHA512 4b2e524607d79638730b86d67e4af0e69294ae0e5e87ca971cf5319e32eee9597b0825149babbf7e0c9a78fd42a1e34fa82eff64c4e22ca61dd478afa95b58a7
DIST tellico-3.3.tar.xz 5618088 BLAKE2B 0896e4df313233e132021047fdd522b527fa1b0b4eea7de36788acbe59bc20cb7556c1a43643c431be51ec813326ff0280b1ba7e49e1486bc9805acaa4b3b808 SHA512 235e29e172eaf41bc07f08691d41ac5e246a2e1be6c2765208440926bce4c6f1d8bf37d4f806c26809a21aebefac7694157cf472656c1a37bca584b7c5ccdc10
89 changes: 89 additions & 0 deletions kde-misc/tellico/tellico-3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
VIRTUALX_REQUIRED="test"
inherit ecm kde.org

DESCRIPTION="Collection manager based on KDE Frameworks"
HOMEPAGE="https://tellico-project.org/"

if [[ ${KDE_BUILD_TYPE} != live ]]; then
SRC_URI="https://tellico-project.org/files/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="5"
IUSE="cddb discid pdf scanner semantic-desktop taglib v4l xmp yaz"

BDEPEND="
sys-devel/gettext
"
RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
>=dev-perl/Text-BibTeX-0.780.0-r1
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
kde-frameworks/karchive:5
kde-frameworks/kcodecs:5
kde-frameworks/kcompletion:5
kde-frameworks/kconfig:5
kde-frameworks/kconfigwidgets:5
kde-frameworks/kcoreaddons:5
kde-frameworks/kcrash:5
kde-frameworks/kguiaddons:5
kde-frameworks/khtml:5
kde-frameworks/kiconthemes:5
kde-frameworks/kitemmodels:5
kde-frameworks/ki18n:5
kde-frameworks/kjobwidgets:5
kde-frameworks/kio:5
kde-frameworks/knewstuff:5
kde-frameworks/kparts:5
kde-frameworks/kservice:5
kde-frameworks/ktextwidgets:5
kde-frameworks/kwallet:5
kde-frameworks/kwidgetsaddons:5
kde-frameworks/kwindowsystem:5
kde-frameworks/kxmlgui:5
kde-frameworks/solid:5
kde-frameworks/sonnet:5
cddb? ( kde-apps/libkcddb:5 )
discid? ( dev-libs/libcdio:= )
pdf? ( app-text/poppler[qt5] )
scanner? ( kde-apps/libksane:5 )
semantic-desktop? ( kde-frameworks/kfilemetadata:5 )
taglib? ( >=media-libs/taglib-1.5 )
v4l? ( >=media-libs/libv4l-0.8.3 )
xmp? ( >=media-libs/exempi-2 )
yaz? ( >=dev-libs/yaz-2:0 )
"
DEPEND="${RDEPEND}"

# tests need network access
RESTRICT+=" test"

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Csv=ON
$(cmake_use_find_package cddb KF5Cddb)
$(cmake_use_find_package discid CDIO)
$(cmake_use_find_package pdf Poppler)
$(cmake_use_find_package scanner KF5Sane)
$(cmake_use_find_package semantic-desktop KF5FileMetaData)
$(cmake_use_find_package taglib Taglib)
-DENABLE_WEBCAM=$(usex v4l)
$(cmake_use_find_package xmp Exempi)
$(cmake_use_find_package yaz Yaz)
)

ecm_src_configure
}

0 comments on commit 58107f5

Please sign in to comment.