Skip to content

Commit

Permalink
media-gfx/slic3r: make v1.2.9 code c++11 compatible for gcc6+
Browse files Browse the repository at this point in the history
Bug: http://bugs.gentoo.org/622338

Package-Manager: Portage-2.3.8, Repoman-2.3.1
  • Loading branch information
axs-gentoo committed Sep 27, 2017
1 parent 6f64b5f commit 583527c
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 1 deletion.
38 changes: 38 additions & 0 deletions media-gfx/slic3r/files/slic3r-1.2.9-c++11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
--- a/xs/src/libslic3r/Config.hpp 2015-06-17 04:38:28.000000000 -0400
+++ b/xs/src/libslic3r/Config.hpp 2017-09-27 10:59:26.527103728 -0400
@@ -65,7 +65,7 @@

bool deserialize(std::string str) {
std::istringstream iss(str);
- return iss >> this->value;
+ return static_cast<bool>(iss >> this->value);
};
};

@@ -124,7 +124,7 @@

bool deserialize(std::string str) {
std::istringstream iss(str);
- return iss >> this->value;
+ return static_cast<bool>(iss >> this->value);
};
};

@@ -249,7 +249,7 @@
bool deserialize(std::string str) {
// don't try to parse the trailing % since it's optional
std::istringstream iss(str);
- return iss >> this->value;
+ return static_cast<bool>(iss >> this->value);
};
};

@@ -279,7 +279,7 @@
bool deserialize(std::string str) {
this->percent = str.find_first_of("%") != std::string::npos;
std::istringstream iss(str);
- return iss >> this->value;
+ return static_cast<bool>(iss >> this->value);
};
};

3 changes: 2 additions & 1 deletion media-gfx/slic3r/slic3r-1.2.9-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -64,6 +64,7 @@ S="${WORKDIR}/Slic3r-${PV}/xs"
src_prepare() {
pushd "${WORKDIR}/Slic3r-${PV}" || die
eapply "${FILESDIR}/${P}-adjust_var_path.patch"
eapply "${FILESDIR}/${P}-c++11.patch"
eapply_user
popd || die
}
Expand Down

0 comments on commit 583527c

Please sign in to comment.