Skip to content

Commit

Permalink
dev-libs/elfutils: use $CC in tests consistently, bug #718872
Browse files Browse the repository at this point in the history
Reported-by: Agostino Sarubbo
Closes: https://bugs.gentoo.org/718872
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed May 30, 2020
1 parent f547e1e commit 58357ad
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
3 changes: 3 additions & 0 deletions dev-libs/elfutils/elfutils-0.179.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
"${FILESDIR}"/${PN}-0.177-disable-large.patch
"${FILESDIR}"/${PN}-0.179-PaX-support.patch
"${FILESDIR}"/${PN}-0.179-CC-in-tests.patch
)

src_prepare() {
Expand Down Expand Up @@ -66,8 +67,10 @@ multilib_src_configure() {
}

multilib_src_test() {
# CC is a workaround for tests using ${CC-gcc}
env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
LC_ALL="C" \
CC="$(gc-getCC)" \
emake check VERBOSE=1
}

Expand Down
45 changes: 45 additions & 0 deletions dev-libs/elfutils/files/elfutils-0.179-CC-in-tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
https://bugs.gentoo.org/718872
--- a/tests/run-disasm-x86-64.sh
+++ b/tests/run-disasm-x86-64.sh
@@ -22,7 +22,7 @@ case "`uname -m`" in
x86_64)
tempfiles testfile45.o
testfiles testfile45.S testfile45.expect
- gcc -m64 -c -o testfile45.o testfile45.S
+ ${CC-gcc} -m64 -c -o testfile45.o testfile45.S
testrun_compare ${abs_top_builddir}/src/objdump -d testfile45.o < testfile45.expect
;;
esac
--- a/tests/run-disasm-x86.sh
+++ b/tests/run-disasm-x86.sh
@@ -22,7 +22,7 @@ case "`uname -m`" in
x86_64 | i?86 )
tempfiles testfile44.o
testfiles testfile44.S testfile44.expect
- gcc -m32 -c -o testfile44.o testfile44.S
+ ${CC-gcc} -m32 -c -o testfile44.o testfile44.S
testrun_compare ${abs_top_builddir}/src/objdump -d testfile44.o < testfile44.expect
;;
esac
--- a/tests/run-strip-g.sh
+++ b/tests/run-strip-g.sh
@@ -25,7 +25,7 @@
tempfiles a.out strip.out debug.out readelf.out

echo Create debug a.out.
-echo "int main() { return 1; }" | gcc -g -xc -
+echo "int main() { return 1; }" | ${CC-gcc} -g -xc -

echo strip -g to file with debug file
testrun ${abs_top_builddir}/src/strip -g -o strip.out -f debug.out ||
--- a/tests/run-strip-nothing.sh
+++ b/tests/run-strip-nothing.sh
@@ -23,7 +23,7 @@
tempfiles a.out strip.out debug.out

# Create no-debug a.out.
-echo "int main() { return 1; }" | gcc -s -xc -
+echo "int main() { return 1; }" | ${CC-gcc} -s -xc -

# strip to file
testrun ${abs_top_builddir}/src/strip -g -o strip.out ||

0 comments on commit 58357ad

Please sign in to comment.