Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.27.16
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 24, 2022
1 parent 5ae9f76 commit 5841046
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,5 @@ DIST aws-cli-1.27.12.gh.tar.gz 2306806 BLAKE2B b94c5ae753754ff66897263883942043f
DIST aws-cli-1.27.13.gh.tar.gz 2308435 BLAKE2B 7b9ec88744417d9b3416f85d26100ab7e07a5373ada8aab004ff0411ff1aededfe21376b4843708a7b861bcf0d47fd5182e8423fcb1a041d1f16380532514a3c SHA512 0888cede49de91790dbd8eedf0b9ec96da10c05d06f939ab0cac983ca24c5f4e2dd8d2f3c11e5543c15c04c86f2bfb0fc49f9d29fe42149a2e3c1e2e04266089
DIST aws-cli-1.27.14.gh.tar.gz 2309344 BLAKE2B dc29dbc89ca963f7dee116b815652c846a643b8415807a32460e86eb9a863470f985bcfcb7f228ce78682b351d14e29234dabc426556f4c7f8863ceec9c55347 SHA512 a97e104c8a45983f52a802d1b1cd55a89f95b1bd3ec5760905404e3f94946c2efe24de70a411d1e943a9ba07671f8114dbb05c216d3d52d1876c05f5e73093cd
DIST aws-cli-1.27.15.gh.tar.gz 2309456 BLAKE2B 17ef8924b61c578462de2ad1eb8e46d16d55a49cc14ca1fa21fd895fa019bcd22bc2eadea498902fd9d440b2d441902c9a78c2b3687aa3cc636894360bdb74b3 SHA512 2e76d318c88bd344ad5336472d6ef1c8231e61b00cfd52f7051bc272966ea1d374584b0f35984441963f7b0d55d74377c3bb4ce60372751d2f2d00043747da72
DIST aws-cli-1.27.16.gh.tar.gz 2309698 BLAKE2B b81d5b1dcc8219a977bfc3cfa41053c12ff8cc363bcb8e3afd9b206d69240a7b4f5ef742d2e74cf21f46bc3a36271a516bf15e1ca34272ad64b4b1dc0c67e4e2 SHA512 1570b82cb2e6cbfb14754b539840b12a606c7a81490bb45239c851757b8e3ac694b41c5842a0b0df825d355d6d6182c6fd6b3c3f26e1c7070150814959c52260
DIST aws-cli-1.27.8.gh.tar.gz 2301766 BLAKE2B 1873d92b8d2f6d3f29a65b4177927a1a14034da71dbc95ff6abf3f49df6cf3ee192412eeea15be14c8cf9fca0a5603f2c76b80b280f4feb95e661055abcd8b60 SHA512 e53828cac1b3e10e2ddd45312d71cdb748216dbc37c3e9833e7a1320b236c3bef6a13204a38b946d9182430f169fca1ddc77d3d06c1c2c6e05978dc61f675168
80 changes: 80 additions & 0 deletions app-admin/awscli/awscli-1.27.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit bash-completion-r1 distutils-r1 multiprocessing

MY_P=aws-cli-${PV}
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="
https://github.com/aws/aws-cli/
https://pypi.org/project/awscli/
"
SRC_URI="
https://github.com/aws/aws-cli/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"

# botocore is x.(y+2).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
!app-admin/awscli-bin
"
BDEPEND="
test? (
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die
# strip overzealous upper bounds on requirements
sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# TODO
tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
)

# integration tests require AWS credentials and Internet access
epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit 5841046

Please sign in to comment.