Skip to content

Commit

Permalink
app-editors/scite: fixes to vn. 3.6.2 sourced from gentoo bug
Browse files Browse the repository at this point in the history
- inherit toolchain-funcs eclass to ensure the build to 'respect CXX',
- add slot operators to deps requiring them (glib, gtk+, lua)
- removed dep sed from deps (set in @System)
fixes the gentoo bug

Gentoo-bug: #Bug 569986

Package-Manager: portage-2.2.28
  • Loading branch information
Ian Delaney committed May 5, 2016
1 parent 4cdb049 commit 585fc69
Showing 1 changed file with 26 additions and 22 deletions.
48 changes: 26 additions & 22 deletions app-editors/scite/scite-3.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
EAPI="6"

inherit toolchain-funcs eutils

Expand All @@ -16,35 +16,38 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="lua"

RDEPEND="dev-libs/glib:2
RDEPEND="dev-libs/glib:=
x11-libs/cairo
x11-libs/gtk+:2
x11-libs/gtk+:2=
x11-libs/gdk-pixbuf
x11-libs/pango
lua? ( >=dev-lang/lua-5:0= )"
lua? ( >=dev-lang/lua-5:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
>=sys-apps/sed-4"
virtual/pkgconfig"

S="${WORKDIR}/${PN}/gtk"

src_prepare() {
cd "${WORKDIR}/scintilla/gtk"
sed -i makefile \
sed -i "${WORKDIR}/scintilla/gtk/makefile" \
-e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
-e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
-e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
-e "s#^CCOMP =\(.*\)#CCOMP = $(tc-getCC)#" \
-e "s#-Os##" \
|| die "error patching makefile"
|| die "error patching /scintilla/gtk/makefile"

cd "${WORKDIR}/scite/gtk"
sed -i makefile \
sed -i "${WORKDIR}/scite/gtk/makefile" \
-e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
|| die "error patching makefile"
|| die "error patching /scite/gtk/makefile"

cd "${S}"
sed -i makefile \
# repair and enhance the .desktop file
sed -i "${WORKDIR}/scite/gtk/SciTE.desktop" \
-e "s/^Encoding/#Encoding/" \
-e "s#text/plain#text/\*;application/xhtml+xml#" \
-e "s#^Categories=\(.*\)#Categories=Development;#" \
|| die "error patching /scite/gtk/SciTe.desktop"

sed -i "${S}/makefile" \
-e 's#usr/local#usr#g' \
-e 's#/gnome/apps/Applications#/applications#' \
-e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
Expand All @@ -54,11 +57,16 @@ src_prepare() {
-e 's#${D}##' \
-e 's#-g root#-g 0#' \
-e "s#-Os##" \
|| die "error patching makefile"
|| die "error patching gtk/makefile"

eapply_user
}

src_compile() {
emake -C ../../scintilla/gtk AR="$(tc-getAR)"
emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
LDFLAGS="$(raw-ldflags)" AR="$(tc-getAR)" \
-C "${WORKDIR}/scintilla/gtk"

if use lua; then
emake
else
Expand All @@ -70,16 +78,12 @@ src_install() {
dodir /usr/bin
dodir /usr/share/{pixmaps,applications}

emake prefix="${ED}/usr" install
emake DESTDIR="${ED}" install

# we have to keep this because otherwise it'll break upgrading
mv "${ED}/usr/bin/SciTE" "${ED}/usr/bin/scite" || die
dosym /usr/bin/scite /usr/bin/SciTE

# replace .desktop file with our own working version
rm -f "${ED}/usr/share/applications/SciTE.desktop" || die
domenu "${FILESDIR}/scite.desktop"

doman ../doc/scite.1
dodoc ../README
}

0 comments on commit 585fc69

Please sign in to comment.