Skip to content

Commit

Permalink
app-portage/gemato: Bump to 12.2
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Apr 4, 2018
1 parent df2c4ef commit 5870046
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/gemato/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gemato-12.1.tar.gz 66807 BLAKE2B 7a6155f337d382bdea7fb4f0bbcb0982e8d4237502dfa7fd8006754bc15e2bfe1f58f133f8cc24ee39eaf947e0770f9ff0672769daa0f03d790ef88958877417 SHA512 7d6287b335121d38859e43ce0818ebb86c51105ed836594f0540fda5ff683a6e58ce09b7dad9cea0667e6379cca6902225b095a3d0922a12cd8c62a36b11386c
DIST gemato-12.2.tar.gz 66897 BLAKE2B 85ca439620afdb2045e571ed7a11f3eb8ce85e41c0984ad51af3b9d22c0926138eda0c7b02e1d70e200eb8c93cf4003e61f901e0fd5fd28861217b02a1e3ab64 SHA512 10ba7da5de3b90722b0bdcf9d3766a7c83c68d29d23e49744a31b0c8ad80eaa4917dff2fbd9f12ef2fa4fde03244e79f6fe5e9c108db7fb64fd6ea68fa0eb81c
34 changes: 34 additions & 0 deletions app-portage/gemato/gemato-12.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# pyblake2 & pysha3 are broken with pypy3
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1

DESCRIPTION="Stand-alone Manifest generation & verification tool"
HOMEPAGE="https://github.com/mgorny/gemato"
SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd"
IUSE="+blake2 bzip2 +gpg lzma sha3 test"

MODULE_RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"

RDEPEND="${MODULE_RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${MODULE_RDEPEND} )"

python_test() {
esetup.py test
}

0 comments on commit 5870046

Please sign in to comment.