forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-base/kdebase-startkde: Merge kdebase-runtime-meta here
Gets rid of slot 5 dependency. Package-Manager: portage-2.2.28 Signed-off-by: Johannes Huber <[email protected]>
- Loading branch information
Showing
3 changed files
with
177 additions
and
12 deletions.
There are no files selected for viewing
130 changes: 130 additions & 0 deletions
130
kde-base/kdebase-startkde/kdebase-startkde-4.11.22-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,130 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KMNAME="kde-workspace" | ||
KMNOMODULE="true" | ||
inherit kde4-meta prefix | ||
|
||
DESCRIPTION="Startkde script, which starts a complete KDE session, and associated scripts" | ||
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="crash-reporter +handbook +wallpapers" | ||
|
||
# The KDE apps called from the startkde script. | ||
# These provide the most minimal KDE desktop. | ||
RDEPEND=" | ||
$(add_kdeapps_dep attica) | ||
$(add_kdeapps_dep kcmshell) | ||
$(add_kdeapps_dep kcontrol) | ||
$(add_kdeapps_dep kdebase-data) | ||
$(add_kdeapps_dep kdebase-desktoptheme) | ||
$(add_kdeapps_dep kdebase-kioslaves) | ||
$(add_kdeapps_dep kdebase-menu) | ||
$(add_kdeapps_dep kdebase-menu-icons) | ||
$(add_kdeapps_dep kdebugdialog) | ||
$(add_kdeapps_dep kdesu) | ||
$(add_kdeapps_dep kdontchangethehostname) | ||
$(add_kdeapps_dep keditfiletype) | ||
$(add_kdeapps_dep kfile) | ||
$(add_kdeapps_dep kfmclient) | ||
$(add_kdeapps_dep kglobalaccel) | ||
$(add_kdeapps_dep kiconfinder) | ||
$(add_kdeapps_dep kimgio) | ||
$(add_kdeapps_dep kioclient) | ||
$(add_kdeapps_dep kmimetypefinder) | ||
$(add_kdeapps_dep knetattach) | ||
$(add_kdeapps_dep knewstuff) | ||
$(add_kdeapps_dep knotify) | ||
$(add_kdeapps_dep knotify) | ||
$(add_kdeapps_dep kpasswdserver) | ||
$(add_kdeapps_dep kquitapp) | ||
$(add_kdeapps_dep kreadconfig) | ||
$(add_kdeapps_dep kstart) | ||
$(add_kdeapps_dep ktimezoned) | ||
$(add_kdeapps_dep ktraderclient) | ||
$(add_kdeapps_dep kuiserver) | ||
$(add_kdeapps_dep kurifilter-plugins) | ||
$(add_kdeapps_dep kwalletd) | ||
$(add_kdeapps_dep kwalletmanager) | ||
$(add_kdeapps_dep phonon-kde) | ||
$(add_kdeapps_dep plasma-apps) | ||
$(add_kdeapps_dep plasma-runtime) | ||
$(add_kdeapps_dep renamedlg-plugins) | ||
$(add_kdeapps_dep solid-runtime) | ||
$(add_kdebase_dep kcminit) | ||
$(add_kdebase_dep krunner) | ||
$(add_kdebase_dep ksmserver) | ||
$(add_kdebase_dep ksplash) | ||
$(add_kdebase_dep kstartupconfig) | ||
$(add_kdebase_dep kwin) | ||
$(add_kdebase_dep plasma-workspace) | ||
$(add_kdebase_dep systemsettings) | ||
x11-apps/mkfontdir | ||
x11-apps/xmessage | ||
x11-apps/xprop | ||
x11-apps/xrandr | ||
x11-apps/xrdb | ||
x11-apps/xsetroot | ||
x11-apps/xset | ||
crash-reporter? ( $(add_kdeapps_dep drkonqi ) ) | ||
handbook? ( kde-apps/khelpcenter:* ) | ||
wallpapers? ( kde-apps/kde-wallpapers:* ) | ||
" | ||
|
||
KMEXTRACTONLY=" | ||
ConfigureChecks.cmake | ||
kdm/ | ||
startkde.cmake | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/gentoo-startkde4-4.patch" | ||
"${FILESDIR}/${PN}-kscreen.patch" | ||
"${FILESDIR}/${PN}-kwalletd-pam.patch" | ||
) | ||
|
||
src_prepare() { | ||
kde4-meta_src_prepare | ||
|
||
cp "${FILESDIR}/KDE-4" "${T}" | ||
|
||
# fix ${EPREFIX} | ||
eprefixify startkde.cmake "${T}/KDE-4" | ||
} | ||
|
||
src_install() { | ||
kde4-meta_src_install | ||
|
||
# startup and shutdown scripts | ||
insinto /etc/kde/startup | ||
doins "${FILESDIR}/agent-startup.sh" | ||
|
||
insinto /etc/kde/shutdown | ||
doins "${FILESDIR}/agent-shutdown.sh" | ||
|
||
# x11 session script | ||
exeinto /etc/X11/Sessions | ||
doexe "${T}/KDE-4" | ||
|
||
# freedesktop compliant session script | ||
sed -e "s:\${BIN_INSTALL_DIR}:${EPREFIX}/usr/bin:g" \ | ||
"${S}/kdm/kfrontend/sessions/kde-plasma.desktop.cmake" > "${T}/KDE-4.desktop" | ||
insinto /usr/share/xsessions | ||
doins "${T}/KDE-4.desktop" | ||
} | ||
|
||
pkg_postinst () { | ||
kde4-meta_pkg_postinst | ||
|
||
echo | ||
elog "To enable gpg-agent and/or ssh-agent in KDE sessions," | ||
elog "edit ${EPREFIX}/etc/kde/startup/agent-startup.sh and" | ||
elog "${EPREFIX}/etc/kde/shutdown/agent-shutdown.sh" | ||
echo | ||
elog "The name of the session script has changed." | ||
elog "If you currently have XSESSION=\"kde-$(get_kde_version)\" in your" | ||
elog "configuration files, you will need to change it to" | ||
elog "XSESSION=\"KDE-4\"" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,12 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo KDE Project</name> | ||
</maintainer> | ||
<use> | ||
<flag name="wallpapers">Install the KDE wallpapers</flag> | ||
</use> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo KDE Project</name> | ||
</maintainer> | ||
<use> | ||
<flag name="crash-reporter">Builds a gui tool to submit crash information to the upstream backtracker</flag> | ||
<flag name="wallpapers">Install the KDE wallpapers</flag> | ||
</use> | ||
</pkgmetadata> |