forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/bitwarden-desktop-bin: add 2022.12.0
Signed-off-by: Michael Palimaka <[email protected]>
- Loading branch information
Michael Palimaka
committed
Jan 8, 2023
1 parent
e7f3ae6
commit 58d58a9
Showing
2 changed files
with
90 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Bitwarden-2022.12.0-amd64.deb 65434808 BLAKE2B 81e7f1b0d7a95fa08554fced72440d65c4fb5fb86371f4ce773904f53543a3586f56eb53d2a4f79034a475430d3b2926404a2bc178e49bb97999295100a6a352 SHA512 ca1fafe48b3dcbab8c2152ed84337c7ebd8cc1934f24d2eabf7ef65733c163e84fc9e49f8566cf2201ab557144e81360db8d8ee1883a92c275804d7c3ddf886b | ||
DIST Bitwarden-2022.9.1-amd64.deb 64957370 BLAKE2B 05d1f206503b41ed2a118948b3bd74cb6418dde661f3e620644abe15108391fcd48e3211cb6ff48560eb6092dc2bd08620f3df24bb92de5b832301202456ecb9 SHA512 5907b58d4da1933809342f482f26833b4513e2b2d2a62a7f2ddec02e571069f3d0a5b509a57c4390f00677dd9c6a6164217e32a5911268da683ef94713345505 |
89 changes: 89 additions & 0 deletions
89
app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2022.12.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,89 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit desktop unpacker xdg-utils | ||
|
||
MY_PN="Bitwarden" | ||
|
||
DESCRIPTION="Bitwarden password manager desktop client" | ||
HOMEPAGE="https://bitwarden.com/" | ||
SRC_URI="https://github.com/bitwarden/clients/releases/download/desktop-v${PV}/Bitwarden-${PV}-amd64.deb" | ||
S="${WORKDIR}" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=" | ||
|| ( | ||
>=app-accessibility/at-spi2-core-2.46.0:2 | ||
( app-accessibility/at-spi2-atk dev-libs/atk ) | ||
) | ||
app-crypt/libsecret | ||
dev-libs/expat | ||
dev-libs/glib | ||
sys-libs/glibc | ||
dev-libs/nspr | ||
dev-libs/nss | ||
media-libs/alsa-lib | ||
media-libs/mesa | ||
net-print/cups | ||
sys-apps/dbus | ||
sys-apps/util-linux | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/gtk+:3 | ||
x11-libs/libdrm | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libXcomposite | ||
x11-libs/libXcursor | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXi | ||
x11-libs/libxkbcommon | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXScrnSaver | ||
x11-libs/libxshmfence | ||
x11-libs/libXtst | ||
x11-libs/pango | ||
" | ||
IDEPEND=" | ||
dev-util/desktop-file-utils | ||
dev-util/gtk-update-icon-cache | ||
" | ||
|
||
QA_PREBUILT=" | ||
opt/Bitwarden/*.so* | ||
opt/Bitwarden/bitwarden | ||
opt/Bitwarden/chrome-sandbox | ||
opt/Bitwarden/chrome_crashpad_handler | ||
" | ||
|
||
src_install() { | ||
insinto /opt | ||
doins -r opt/${MY_PN} | ||
fperms 755 /opt/Bitwarden/bitwarden | ||
fperms 4755 /opt/Bitwarden/chrome-sandbox | ||
|
||
domenu usr/share/applications/bitwarden.desktop | ||
|
||
local x | ||
for x in 16 32 64 128 256 512; do | ||
doicon -s ${x} usr/share/icons/hicolor/${x}*/* | ||
done | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
xdg_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
xdg_icon_cache_update | ||
} |