Skip to content

Commit

Permalink
app-office/scribus: fixed building with boost 1.85
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/932492
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
fordfrog committed Jun 4, 2024
1 parent eaa01a4 commit 58e7194
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 0 deletions.
27 changes: 27 additions & 0 deletions app-office/scribus/files/scribus-1.6.1-boost-1.85-2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 3116328e804c7366ec64c4224cbf20b0f14e52c8 Mon Sep 17 00:00:00 2001
From: Jean Ghali <[email protected]>
Date: Sun, 31 Mar 2024 21:40:42 +0000
Subject: [PATCH] Fix C++20 related warning "template-id is not allowed for
constructor in C++20"

git-svn-id: svn://scribus.net/trunk/Scribus@26079 11d20701-8431-0410-a711-e3c959e3b870
--- a/scribus/third_party/lib2geom/rect.h
+++ b/scribus/third_party/lib2geom/rect.h
@@ -56,14 +56,14 @@ class D2<Interval> {
private:
Interval f[2];
public:
- D2<Interval>() { f[X] = f[Y] = Interval(0, 0); }
+ D2() { f[X] = f[Y] = Interval(0, 0); }

- D2<Interval>(Interval const &a, Interval const &b) {
+ D2(Interval const &a, Interval const &b) {
f[X] = a;
f[Y] = b;
}

- D2<Interval>(Point const & a, Point const & b) {
+ D2(Point const & a, Point const & b) {
f[X] = Interval(a[X], b[X]);
f[Y] = Interval(a[Y], b[Y]);
}
1 change: 1 addition & 0 deletions app-office/scribus/scribus-1.6.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.6.1-poppler-24.03.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.05.patch
"${FILESDIR}"/${PN}-1.6.1-boost-1.85.patch
"${FILESDIR}"/${PN}-1.6.1-boost-1.85-2.patch
)

src_prepare() {
Expand Down

0 comments on commit 58e7194

Please sign in to comment.