forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-themes/lovelock-backgrounds: EAPI bump, bug 605728
Package-Manager: Portage-2.3.6, Repoman-2.3.3
- Loading branch information
Showing
1 changed file
with
35 additions
and
0 deletions.
There are no files selected for viewing
35 changes: 35 additions & 0 deletions
35
x11-themes/lovelock-backgrounds/lovelock-backgrounds-14.91.1.1-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit versionator rpm | ||
|
||
SRC_PATH=releases/15/Fedora/source/SRPMS | ||
FEDORA=15 | ||
|
||
MY_P="${PN}-$(get_version_component_range 1-3)" | ||
|
||
DESCRIPTION="Fedora official background artwork" | ||
HOMEPAGE="https://fedoraproject.org/wiki/F15_Artwork" | ||
|
||
SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm" | ||
|
||
LICENSE="CC-BY-SA-3.0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="" | ||
DEPEND="" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
SLOT=0 | ||
|
||
src_compile() { :; } | ||
src_test() { :; } | ||
|
||
src_install() { | ||
# The install targets are serial anyway. | ||
emake -j1 DESTDIR="${D}" install || die "emake install failed" | ||
} |