Skip to content

Commit

Permalink
dev-ml/facile: bump to 1.1.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Mar 28, 2016
1 parent fa54584 commit 5920fe2
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/facile/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST facile-1.1.1.tar.gz 99454 SHA256 150a6c269277ce14e9c953dbcf409bfedc795abc1558ac6e338609b1e64fa38c SHA512 2e14c65f9c8d0d7363a2c7bd117ebc52fe1949e6e364e0e8d33b25880d3a505bc92b7d26f33d6b7deed09dc6d8eaeb0274d69dbb5fdb2d217bbd9eafb5efc2ae WHIRLPOOL cd08ccc78466b0d858fa6645805226d8d19f021a1bf0f52743fa99ee73f833774c1b240c77780c104380ec45ef076a2d85847f2fc13d6e3816cbd7b1b5f71b6a
DIST facile-1.1.2.tar.gz 99755 SHA256 ea8b72d1d171fb44c0c6dafbddac0ccb0a453a7caafd1852919d4f805eded367 SHA512 12c086a9e1d7b2d76c36fa3d7b519da24199bb958b56050d5635cd6eb0288b6d98845b4ade74e22127b2abd405f359b0a33cfd776042187f3ab506ad656676df WHIRLPOOL d643b8b7151fa262542f6408acda23b6a29466b48fc288ea9efc8b024c418e95ca50ef005a09c61f6030faddbff6d2f013b1ffddd4544291f8387b29303a0a32
DIST facile-1.1.tar.gz 96343 SHA256 a87a6ba7869104f85828c19a9681758bd1d01c816581ba09ac483739ad4ae5ca SHA512 5048daa30bc0de47465f3978cc9079e29407e35f03a3e0d6656b61838e750f62370562e26b5377d30afa478974f19e962a4a3b5a4f8fbd6661bf6f6485d90565 WHIRLPOOL a3aa0b50e51042fcdb90dffb62da483730738c1ed48eadcc1a329cc2f6529a985f50efe157231cc566ca909194468fb505ced2d653f71c3c39fd85a32e2d4558
51 changes: 51 additions & 0 deletions dev-ml/facile/facile-1.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

DESCRIPTION="A constraint programming library on integer and integer set finite domains written in OCaml"
HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
SRC_URI="http://www.recherche.enac.fr/log/facile/distrib/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0/${PV}"

KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="+ocamlopt"

RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
DEPEND="${RDEPEND}
sys-apps/sed"

src_prepare() {
# Fix building on FreeBSD
epatch "${FILESDIR}/${PN}"-1.1-make.patch
# Disable building native code objects if we dont have/want ocamlopt
if ! use ocamlopt; then
sed -i -e 's/\.opt//' src/Makefile || die "failed to change native code compiler to bytecode ones"
sed -i -e 's/ facile\.cmxa//' src/Makefile || die "failed to remove native code objects"
sed -i -e 's/\.opt/.out/g' \
-e 's: src/facile\.cmxa::'\
-e 's: src/facile\.a::'\
-e 's:^.*facile\.cmxa::'\
-e 's:^.*facile\.a::' Makefile || die "failed to remove native code objects"
fi
}

src_configure(){
# This is a custom configure script and it does not support standard options
./configure --faciledir "${D}"$(ocamlc -where)/facile/ || die
}

src_test() {
emake check
}

src_install(){
dodir $(ocamlc -where)
emake install
dodoc README
}

0 comments on commit 5920fe2

Please sign in to comment.