Skip to content

Commit

Permalink
kde-misc/bismuth: add 3.1.4
Browse files Browse the repository at this point in the history
Closes: gentoo#27649
Signed-off-by: Alfred Wingate <[email protected]>
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
parona-source authored and gyakovlev committed Oct 10, 2022
1 parent b1e3b13 commit 5932b29
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
2 changes: 2 additions & 0 deletions kde-misc/bismuth/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST bismuth-3.1.3-binary-release.tar.gz 187092 BLAKE2B 76672973b2102dffc3b5db9a00f49a291ac07e9b79ef282a9fe24a33ddd641cdebbaea20fd149f293625ff800000c4bf7aa28f40f62291c94ed3828540728b35 SHA512 6c42a4075dd97e3429075e69fd0604ef273afb4a22ec4dc14073ca2e02fd325ad8f6defc3943eec1e3a11a598c6ace41ac8825ba36b8d7d976b98d2d00cc1e73
DIST bismuth-3.1.3.tar.gz 5473759 BLAKE2B fcacf2e6b491bbaccf52ec1227196b3a06535ae23371544762868b28b18ab5fe7cd0540376fd7ee34ac6d3fcd52d3ce61760c0252ff91acd7bc78896602e4c62 SHA512 fdfa1074d8c156c24cfe8b97ac99f1252c221f0ee2039d440645a08d6da405b7bf9b0479f1752cfadc9d05c21d3ad86923498cc190d69cc5f278c36888330a0c
DIST bismuth-3.1.4-binary-release.tar.gz 131470 BLAKE2B 435ec224ed589300f48bfd0f25aec75cb955ca7b6948ec48cdf0f8b53b92d262366e4159fb02862fde5bf676a99bfce38b521bcb670285fde7bb7dbda3e596d3 SHA512 90693137fa9527ed7aca9c0cad18d849491a166d3f6e6d4545f3c325a062589a196e1bfc36569f94551ba8a112e3f0be9a9d14dcb6cad0c8bc4e49bdd61f6488
DIST bismuth-3.1.4.tar.gz 5456820 BLAKE2B 397f1f2ab89b92a2d0e9aa37f0cb42282f40b581de499860617ab2333a56e503bd8b76c4e6c909ec16df5ed56eb38019d559333c670898ab3f79fc1ab24310ad SHA512 3318f010dc9bf217536cccf2b9a683637172fae90409c2fbae4152a6b613d1a850cd7c7a03880e46f812aaa3a8d66bb829ba70f028a6a320db7844e254d73cc3
68 changes: 68 additions & 0 deletions kde-misc/bismuth/bismuth-3.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake xdg

DESCRIPTION="Tiling window management script for Kwin"
HOMEPAGE="https://github.com/Bismuth-Forge/bismuth"
SRC_URI="
https://github.com/Bismuth-Forge/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/Bismuth-Forge/bismuth/releases/download/v${PV}/binary-release.tar.gz -> ${P}-binary-release.tar.gz
"

LICENSE="CC-BY-4.0 LGPL-3+ MIT"
SLOT="0"
KEYWORDS="~amd64"

QTMIN=5.15.0
KFMIN=5.78.0

DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtquickcontrols2-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
>=dev-qt/qttest-${QTMIN}:5
>=kde-frameworks/kcmutils-${KFMIN}:5
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kconfigwidgets-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kdeclarative-${KFMIN}:5
>=kde-frameworks/kglobalaccel-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-plasma/kwin-5.24.0:5
"

RDEPEND="${DEPEND}"

RESTRICT=test # npm + js + hell + network

src_prepare() {
# we are not building npm hell or tests
cmake_comment_add_subdirectory tests
cmake_run_in src cmake_comment_add_subdirectory kwinscript
cmake_src_prepare
}

src_configuire() {
# cmake calls git describe --tags --abbrev=0
# let's just echo expected output, e.g. v1.2.3
git() { echo "v${PV}" ; }
export -f git || die

local mycmakeargs=(
-DBUILD_TESTING=OFF
-DUSE_NPM=OFF
-DUSE_TSC=OFF
)

cmake_src_configure
}

src_install() {
cmake_src_install

insinto /usr/share/kwin/scripts
doins -r ../share/kwin/scripts/"${PN}"
}

0 comments on commit 5932b29

Please sign in to comment.