Skip to content

Commit

Permalink
dev-python/jinja: Bump to 2.11.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 14, 2020
1 parent 3ff5c06 commit 5956e39
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/jinja/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jinja-2.11.1.tar.gz 258637 BLAKE2B 80826397ada553b2bd1452f72430589ddebbd55aecffe6c6d9161ddcb46d9caa35635abd0946e063efda856391843831d25a7de91250d0f066b12cbf8b4af988 SHA512 66d9b7923f4b78133489bc28525d83032d37d5409ac572c00ea1aa342b3291bf0505c1e9d62f7a553553e26f06885e3d5c71bdcd2b334064b610692681694d33
DIST jinja-2.11.2.tar.gz 258055 BLAKE2B 5cf12d6c79e7e659b16318cb3dc483a276511192903469629ec497c10ba6cd023f5a834961ac74cbda556177aaac46f5045c5aaca3068dcef87017760895851c SHA512 453e0c94c57065ab78f997726256bd2a31bb79124a2ee17b632cb124a3ccefded33d81b35cac73497f095b1cd5d8cd4420d6932a637fd7c4cdb786f1753e49ac
DIST jinja-2.8.1.tar.gz 397144 BLAKE2B 78e4903da05ab3e8961b6bb6047116941b4bbf59d08b8283582972590409f98b5dc1f468a988525d96c552000279fcd0a31dae3ac1e5226f609a8854c8f9ca0b SHA512 f4655f1a43c06f7651fbd5251d0538788a3a6a3ffb93d9a8c239711cf043082c43d34706b6d71a18679d957faa6590e7e0259ffb8f7cc5e3300749526417a987
68 changes: 68 additions & 0 deletions dev-python/jinja/jinja-2.11.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="A full-featured template engine for Python"
HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
# pypi tarball is missing tests
SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="examples"

RDEPEND="
dev-python/markupsafe[${PYTHON_USEDEP}]
!dev-python/jinja:compat"

distutils_enable_sphinx docs \
dev-python/sphinx-issues \
dev-python/pallets-sphinx-themes
distutils_enable_tests pytest

# XXX: handle Babel better?

src_prepare() {
# avoid unnecessary dep on extra sphinxcontrib modules
sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die

distutils-r1_src_prepare
}

python_compile() {
distutils-r1_python_compile

if ! python_is_python3; then
rm "${BUILD_DIR}"/lib/jinja2/async*.py || die
fi
}

python_install() {
distutils-r1_python_install --skip-build
}

python_install_all() {
if use examples ; then
docinto examples
dodoc -r examples/.
fi

distutils-r1_python_install_all

insinto /usr/share/vim/vimfiles/syntax
doins ext/Vim/*
}

pkg_postinst() {
if ! has_version dev-python/Babel; then
elog "For i18n support, please emerge dev-python/Babel."
fi
}

0 comments on commit 5956e39

Please sign in to comment.