forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.48, Repoman-2.3.10
- Loading branch information
1 parent
15db12e
commit 599365d
Showing
3 changed files
with
287 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glance-15.0.1.tar.gz 1815463 BLAKE2B ec6e51340fc4d737e2bd777baf03163a0b515d19c1dc8e5203918e07b304a9539f47ba763207e26def985c6a384d21250ffe1386b433d8b606b55d3d70e4431a SHA512 2da3ada256424a7817d0c49aac0940443cbefcfff3df77a623d7099badf356808b5df59f109ac233f84ac561b7310d3b8d53cafd6c9955a8e2b296a1655cedd3 | ||
DIST glance-16.0.1.tar.gz 1957403 BLAKE2B a58a37b1926432ff227ebbd2b8538d25276085c4183244f930cdb6432ce00ed3927130ede24faeb9ebd25489f649c7f6542d71b9fe9614859ed3953bded13ab2 SHA512 dad883c308cfa6799bd5fc4111585af2bd7f2c5a20126976d1044e2bf573f94756f2ecea87f3b04fe611f80602709e0501c0efceed5061d0c752416b6255a2a2 | ||
DIST glance-17.0.0.tar.gz 1961137 BLAKE2B ff649ce366739320bcc5073cb60cc24ab09e098bd6808374007f89808d6caf020a77f711a714b34f8a1ef5b0754220aab7c35c02fbdc0d3d0f44e24185a8cdc4 SHA512 cd10bd2d3e98ab1a80ec4f09b5954dbc334079a36d3dfc0d27c5a4f40e5920e0a6fb91c0fc5430c9e625a375e44a8d886568f2a712190dc0f80df10b4998e9af |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,143 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} ) | ||
|
||
inherit distutils-r1 user | ||
|
||
DESCRIPTION="Services for discovering, registering, and retrieving VM images" | ||
HOMEPAGE="https://launchpad.net/glance" | ||
|
||
if [[ ${PV} == *9999 ]];then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/openstack/glance.git" | ||
EGIT_BRANCH="stable/rocky" | ||
else | ||
SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
fi | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="doc mysql postgres +sqlite +swift" | ||
REQUIRED_USE="|| ( mysql postgres sqlite )" | ||
|
||
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/pbr-2.1.0" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND}" | ||
|
||
#note to self, wsgiref is a python builtin, no need to package it | ||
#>=dev-python/wsgiref-0.1.2[${PYTHON_USEDEP}] | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}] | ||
sqlite? ( | ||
>=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[sqlite,${PYTHON_USEDEP}] | ||
) | ||
mysql? ( | ||
>=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}] | ||
!~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}] | ||
) | ||
postgres? ( | ||
>=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}] | ||
) | ||
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}] | ||
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}] | ||
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/routes-2.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}] | ||
>=dev-python/alembic-0.8.10[${PYTHON_USEDEP}] | ||
>=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}] | ||
>=dev-python/futurist-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystonemiddleware-4.17.0[${PYTHON_USEDEP}] | ||
>=dev-python/WSME-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/paste-2.0.2[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-db-4.27.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-policy-1.30.0[${PYTHON_USEDEP}] | ||
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}] | ||
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/glance_store-0.26.1[${PYTHON_USEDEP}] | ||
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-2.1[${PYTHON_USEDEP}] | ||
>=dev-python/cursive-0.2.1[${PYTHON_USEDEP}] | ||
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}] | ||
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}] | ||
" | ||
|
||
#PATCHES=( | ||
#) | ||
|
||
pkg_setup() { | ||
enewgroup glance | ||
enewuser glance -1 -1 /var/lib/glance glance | ||
} | ||
|
||
python_prepare_all() { | ||
sed -i '/xattr/d' test-requirements.txt || die | ||
sed -i '/pysendfile/d' test-requirements.txt || die | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && "${PYTHON}" setup.py build_sphinx | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
newinitd "${FILESDIR}/glance.initd" glance-api | ||
|
||
diropts -m 0750 -o glance -g glance | ||
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber | ||
keepdir /etc/glance | ||
keepdir /var/log/glance | ||
keepdir /var/lib/glance/images | ||
keepdir /var/lib/glance/scrubber | ||
|
||
insinto /etc/glance | ||
insopts -m 0640 -o glance -g glance | ||
doins -r etc/*.ini etc/*.conf etc/*.sample etc/*.json etc/meta* | ||
|
||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,143 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} ) | ||
|
||
inherit distutils-r1 user | ||
|
||
DESCRIPTION="Services for discovering, registering, and retrieving VM images" | ||
HOMEPAGE="https://launchpad.net/glance" | ||
|
||
if [[ ${PV} == *9999 ]];then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/openstack/glance.git" | ||
EGIT_BRANCH="stable/rocky" | ||
else | ||
SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
fi | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="doc mysql postgres +sqlite +swift" | ||
REQUIRED_USE="|| ( mysql postgres sqlite )" | ||
|
||
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/pbr-2.1.0" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND}" | ||
|
||
#note to self, wsgiref is a python builtin, no need to package it | ||
#>=dev-python/wsgiref-0.1.2[${PYTHON_USEDEP}] | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}] | ||
sqlite? ( | ||
>=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[sqlite,${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[sqlite,${PYTHON_USEDEP}] | ||
) | ||
mysql? ( | ||
>=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}] | ||
!~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}] | ||
) | ||
postgres? ( | ||
>=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}] | ||
!~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}] | ||
) | ||
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}] | ||
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}] | ||
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/routes-2.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}] | ||
>=dev-python/alembic-0.8.10[${PYTHON_USEDEP}] | ||
>=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}] | ||
>=dev-python/futurist-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/taskflow-2.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystonemiddleware-4.17.0[${PYTHON_USEDEP}] | ||
>=dev-python/WSME-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/paste-2.0.2[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-db-4.27.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-policy-1.30.0[${PYTHON_USEDEP}] | ||
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}] | ||
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/glance_store-0.26.1[${PYTHON_USEDEP}] | ||
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-2.1[${PYTHON_USEDEP}] | ||
>=dev-python/cursive-0.2.1[${PYTHON_USEDEP}] | ||
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}] | ||
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}] | ||
" | ||
|
||
#PATCHES=( | ||
#) | ||
|
||
pkg_setup() { | ||
enewgroup glance | ||
enewuser glance -1 -1 /var/lib/glance glance | ||
} | ||
|
||
python_prepare_all() { | ||
sed -i '/xattr/d' test-requirements.txt || die | ||
sed -i '/pysendfile/d' test-requirements.txt || die | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && "${PYTHON}" setup.py build_sphinx | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
newinitd "${FILESDIR}/glance.initd" glance-api | ||
|
||
diropts -m 0750 -o glance -g glance | ||
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber | ||
keepdir /etc/glance | ||
keepdir /var/log/glance | ||
keepdir /var/lib/glance/images | ||
keepdir /var/lib/glance/scrubber | ||
|
||
insinto /etc/glance | ||
insopts -m 0640 -o glance -g glance | ||
doins -r etc/*.ini etc/*.conf etc/*.sample etc/*.json etc/meta* | ||
|
||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |