forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Have successfully made the ebuild run tests depending on dev-cpp/gtest too, however since the required version of the latter is not in the tree yet the committed ebuild has that bit disabled. Signed-off-by: Marek Szuba <[email protected]>
- Loading branch information
Marek Szuba
committed
Aug 13, 2021
1 parent
d7c239b
commit 599c870
Showing
3 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST benchmark-1.5.3.tar.gz 163465 BLAKE2B cea8929c5595be55e74e6232eb147a00c656cc5afe6f5b9d3d788de002c51c40c46012461a7c6840aff9e590ed4304f24a31249402bbbeae28ec443a433a2e53 SHA512 11f726686ad8b36870fc2a3542fad4c52a58df2eb580564dcfdfb154fe6ac00dbbf69c514395148d7ab11a45e40e869549cf971462c384f59cbae5fa60160e3b | ||
DIST benchmark-1.5.5.tar.gz 176710 BLAKE2B 394f8b34873ccd45100e3b1f58dd7819d443733d9224ff003a9410ca30d8bacc6c7736b74dd50623144767e840dbc3cd9ff819a60de6e22a00b1edaf802f0992 SHA512 91a2cdf0245625c657b9bb8d76c7d616a99eaed333e42b34ceff4e996b8fa6027b1c7313a815e7b441d2f6e2e1244c139a0911d585bf0d2e767ac3cea23a67d1 | ||
DIST benchmark-1.5.6.tar.gz 177911 BLAKE2B ea4e98cb98471b2b8e2371109b96017bc483459dc924deaa1d9770b065de946ea2d69ca36098c27283f15370699f2475448af1e205cfca3d9c64408f08c202a9 SHA512 b3c1fd4407d660456ae51abd7c427460a2c7b029ab6344e21bb61d3ec84e3b60638b7a719655aa04fb9ca639b6371e553e9de18539aca8dd38c361b4c6522538 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake | ||
|
||
DESCRIPTION="A microbenchmark support library" | ||
HOMEPAGE="https://github.com/google/benchmark" | ||
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~riscv ~x86" | ||
IUSE="debug test" | ||
|
||
RESTRICT="!test? ( test )" | ||
|
||
# Version not in the tree yet | ||
#BDEPEND="test? ( >=dev-cpp/gtest-1.11.0 )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-1.5.6-system_testdeps.patch | ||
) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBENCHMARK_ENABLE_TESTING=$(usex test) | ||
-DBENCHMARK_ENABLE_GTEST_TESTS=OFF | ||
-DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF | ||
) | ||
|
||
use debug || append-cppflags -DNDEBUG | ||
|
||
cmake_src_configure | ||
} |
11 changes: 11 additions & 0 deletions
11
dev-cpp/benchmark/files/benchmark-1.5.6-system_testdeps.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -307,7 +307,7 @@ | ||
if (BENCHMARK_ENABLE_GTEST_TESTS AND | ||
NOT (TARGET gtest AND TARGET gtest_main AND | ||
TARGET gmock AND TARGET gmock_main)) | ||
- include(GoogleTest) | ||
+ find_package(GTest 1.11 REQUIRED) | ||
endif() | ||
add_subdirectory(test) | ||
endif() |