Skip to content

Commit

Permalink
sys-cluster/cinder: bup
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
prometheanfire committed Sep 21, 2016
1 parent 2bd1c62 commit 59c610e
Show file tree
Hide file tree
Showing 2 changed files with 183 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/cinder/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST cinder-8.1.0.tar.gz 3860875 SHA256 f2bd093ee6ed56b10a694e198eb2b3b436340b492d2bb1c6ae85eba5ef1e0326 SHA512 df6be20bfa90c6b1603125986e9b1b90f9f5e86b07a72acf52f53bd68adbc6971b5b9b88b70a312647d8306480ef55eade8cbe747d27646b302f886972631abb WHIRLPOOL 3516447f85bd2cecb907931d0c3eb0c379f2246c97be94b80549d01da68830d82d0dfe5967b153a287e98ee3a833c6d27491f5e3cb21a989bec490117c3b1b75
DIST cinder-8.1.1.tar.gz 3875392 SHA256 57de9d1410e9e5a0568499e38414241167e4b2b1742aac309844da80efd127e2 SHA512 4dfa5a11b11b684761519b33d1b45f4d65152df96fc9303e92724f88a01bea031e0dd7aaa229d5876641fa4a5089fcd197e52cf01652a89f6027435b038f3560 WHIRLPOOL 9815230914da588529f3f3916ddfdb25025a531015fd78fce635a6e55b6051f2a26f2e4710cd980daceb905f41caaceb274f84c34353bbc363a36e12a88c8245
DIST mitaka-cinder-api-paste.ini 2416 SHA256 3794a5e34dace60474274e93a7346662eb03a485d1b9b67afded591e764aba9d SHA512 f6e3800557fa7efb562a69f80eea9b516c0ad2e54b9a013c92118bf91daaf2bdd2a9ced309626fab13fe9b979f0c768ac22bba63c7fa8aa3443004d50359d844 WHIRLPOOL 90e8c7bf065609e6a85d247c15b1022ea51bb94b000841c30a69d99c96082a08125fca58cf5b216990c6b746f52af5cedebbafc5b9450a91c0d32cdc21951952
DIST mitaka-cinder-policy.json 4959 SHA256 5a9cd9d5d4cf80a9271fd7a5146d6d5415d10f8d699a8499a39a3cde29f50bd6 SHA512 b36daa51ab7719e1a56ca760e7ec62a98fb3a88ffed96196852023abf4ffe483200c9dcb934e3c7910fc6988f9c2bb9bb914121d0d649dc3b01466f467a82fe2 WHIRLPOOL f288b6dba2593fa6deb8ad94862948899ec10f71e4751f108ec1fbfff814c3206b5c541aaac0bb7edd2fb5311639a1cd3a44586855912cb2e0e675d5ad78161c
DIST mitaka-cinder-volume.filters 9819 SHA256 20e4833aaf18b6be247e8ea2a0f63cc509ed595ea799c3ccfbcc1d0afc5bf9d8 SHA512 7b7aacdd843b960ed075b466e0bd7d2973a7733e7db63b4cb02df4b824a9528f6b7074870bf0048674e600bed983bc66caa1914963fff4aed00e8ab40e2ef600 WHIRLPOOL 32fb88041b8f38c821896d82139ea712ea0fc0a71bd6154e31887e85baf58d80b2c8bfd6c60b21613e522fe32fb022078091fcdc74110e5c9968826ae218c085
Expand Down
182 changes: 182 additions & 0 deletions sys-cluster/cinder/cinder-8.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,182 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1 eutils linux-info user

DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
HOMEPAGE="https://launchpad.net/cinder"
SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz
https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/mitaka/cinder.conf.sample -> mitaka-cinder.conf.sample
https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/mitaka/api-paste.ini -> mitaka-cinder-api-paste.ini
https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/mitaka/policy.json -> mitaka-cinder-policy.json
https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/mitaka/volume.filters -> mitaka-cinder-volume.filters"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+api +scheduler +volume iscsi lvm mysql +memcached postgres sqlite test"
REQUIRED_USE="|| ( mysql postgres sqlite )"

CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
app-admin/sudo"

RDEPEND="
${CDEPEND}
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
!~dev-python/Babel-2.3.0[${PYTHON_USEDEP}]
!~dev-python/Babel-2.3.1[${PYTHON_USEDEP}]
!~dev-python/Babel-2.3.2[${PYTHON_USEDEP}]
!~dev-python/Babel-2.3.3[${PYTHON_USEDEP}]
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
dev-python/enum34[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
>=dev-python/keystonemiddleware-4.0.0[${PYTHON_USEDEP}]
!~dev-python/keystonemiddleware-4.1.0[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/oauth2client-1.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-3.7.1[${PYTHON_USEDEP}]
>=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-4.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
>=dev-python/oslo-messaging-4.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-reports-0.6.0[${PYTHON_USEDEP}]
>=dev-python/oslo-rootwrap-2.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-service-1.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-versionedobjects-1.5.0[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.1.0[${PYTHON_USEDEP}]
>=dev-python/paramiko-1.16.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
>=dev-python/python-barbicanclient-3.3.0[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-2.0.0[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
!~dev-python/python-keystoneclient-1.8.0[${PYTHON_USEDEP}]
!~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
<dev-python/python-keystoneclient-3.0.0[${PYTHON_USEDEP}]
>=dev-python/python-novaclient-2.29.0[${PYTHON_USEDEP}]
!~dev-python/python-novaclient-2.33.0[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-2.2.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
>=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
!~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
!~dev-python/routes-2.0[${PYTHON_USEDEP}]
!~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
!~dev-python/routes-2.3.0[${PYTHON_USEDEP}]
>=dev-python/taskflow-1.26.0[${PYTHON_USEDEP}]
>=dev-python/rtslib-fb-2.1.41[${PYTHON_USEDEP}]
>=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
)
mysql? (
dev-python/mysql-python
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
)
postgres? (
dev-python/psycopg:2
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
~dev-python/suds-0.6[${PYTHON_USEDEP}]
>=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-vmware-1.16.0[${PYTHON_USEDEP}]
>=dev-python/os-brick-1.0.0[${PYTHON_USEDEP}]
!~dev-python/os-brick-1.4.0[${PYTHON_USEDEP}]
>=dev-python/os-win-0.2.3[${PYTHON_USEDEP}]
>=dev-python/tooz-1.28.0[${PYTHON_USEDEP}]
>=dev-python/google-api-python-client-1.4.2[${PYTHON_USEDEP}]
iscsi? (
sys-block/tgt
sys-block/open-iscsi
)
lvm? ( sys-fs/lvm2 )
memcached? ( net-misc/memcached )
app-emulation/qemu
sys-fs/sysfsutils"
# qemu is needed for image conversion

#PATCHES=(
#)

pkg_setup() {
linux-info_pkg_setup
CONFIG_CHECK_MODULES="ISCSI_TCP"
if linux_config_exists; then
for module in ${CONFIG_CHECK_MODULES}; do
linux_chkconfig_present ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
done
fi
enewgroup cinder
enewuser cinder -1 -1 /var/lib/cinder cinder
}

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

python_test() {
# Let's track progress of this # https://bugs.launchpad.net/swift/+bug/1249727
nosetests -I test_wsgi.py cinder/tests/ || die "tests failed under python2.7"
}

python_install() {
distutils-r1_python_install
keepdir /etc/cinder
dodir /etc/cinder/rootwrap.d

for svc in api scheduler volume; do
newinitd "${FILESDIR}/cinder.initd" cinder-${svc}
done

insinto /etc/cinder
insopts -m0640 -o cinder -g cinder
doins "etc/cinder/api-httpd.conf"
doins "etc/cinder/logging_sample.conf"
doins "etc/cinder/rootwrap.conf"
newins "${DISTDIR}/mitaka-cinder-api-paste.ini" "api-paste.ini"
newins "${DISTDIR}/mitaka-cinder-policy.json" "policy.json"
newins "${DISTDIR}/mitaka-cinder.conf.sample" "cidner.conf.sample"
insinto /etc/cinder/rootwrap.d
newins "${DISTDIR}/mitaka-cinder-volume.filters" "volume.filters"

dodir /var/log/cinder
fowners cinder:cinder /var/log/cinder

#add sudoers definitions for user nova
insinto /etc/sudoers.d/
insopts -m 0440 -o root -g root
newins "${FILESDIR}/cinder.sudoersd" cinder
}

pkg_postinst() {
if use iscsi ; then
elog "Cinder needs tgtd to be installed and running to work with iscsi"
elog "it also needs 'include /var/lib/cinder/volumes/*' in /etc/tgt/targets.conf"
fi
}

0 comments on commit 59c610e

Please sign in to comment.