Skip to content

Commit

Permalink
dev-python/flask-mongoengine: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
dev-zero committed Nov 6, 2016
1 parent a9f77dd commit 59d2fcb
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/flask-mongoengine/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST flask-mongoengine-0.7.0.tar.gz 103676 SHA256 e5031d1f812181699b10fec76d7c9c6633f19f8b686dcee48371e9216884f2b4 SHA512 3a9ce923b5d391e4fbdacc87d32e6cd8e0ada592c9fce585cf6dc38b8c116966cd70c83c2f2b77f580348722351c129ef38d7788f9ae2bd27d043de0d5487493 WHIRLPOOL 20583285ec18871b750c045a1dc911d6c836b152a27816b81805f12808dd68450236139245fd6ea07c9239544a7a62dafd358feaf13304910b6c6301f5f32567
DIST flask-mongoengine-0.7.1.tar.gz 103947 SHA256 8ab895611a92b1e16f8467ddda0d4e8addee0ccf478f61d161ff58417caa06f2 SHA512 5da5c0a9794a108c2ff3adc3a6a415216841f060db54483b96421769879e7961c1137b787ad2ebd0ceb80a2187e4c7eaaecca4cb57c517e43aaf4845ac618c99 WHIRLPOOL afb4cf0a02678d1f4cfaa9c6d35d6086cf2e1f49a4b739348463173175f5928c7bacb2eecd3257bb0782021a5276761c187377ca3f2ec80560cdd086a86aa5c9
DIST flask-mongoengine-0.8.tar.gz 115524 SHA256 24b30f3cfce95a53f0ad7ce14aa5eb24db7a6db756e1549056fb2b4b397b045e SHA512 fe64765f5ce5e9d9b6919b29bae5ed0faff98e42f2ae99283c8492e5c82def0ec90afabade92dd8ee7805ca65dd6f529b266c8518a95328422f57d5ab18283e3 WHIRLPOOL c38f5c00de4f8bbebe045a1b7d4ef7f9460209c4f2eac17e0a00dc7b86f1550a5e6f3a601ee00f9f107d05345e07b195ece63198bd31ecaad72dacd4e38acb88
45 changes: 45 additions & 0 deletions dev-python/flask-mongoengine/flask-mongoengine-0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )

inherit distutils-r1

RESTRICT="test" # requires running MongoDB server

DESCRIPTION="Flask support for MongoDB and with WTF model forms"
HOMEPAGE="https://pypi.python.org/pypi/flask-mongoengine/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
>=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
dev-python/flask-wtf[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"

python_prepare_all() {
# fix distutils sandbox violation due to missing test-deps in normal build
sed -i '/test_requirements/d' setup.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
nosetests || die "Testing failed with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 59d2fcb

Please sign in to comment.