Skip to content

Commit

Permalink
dev-python/hiredis: Bump to 2.2.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 8, 2023
1 parent 39e7caf commit 59e4c93
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/hiredis/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hiredis-2.2.2.gh.tar.gz 18010 BLAKE2B 67ab7c3f0667d3cf33abea58fbe37bcc28beb569f6f3da966f191d00965faa5a835a286172179d6f33f4e0fa81743fa345829f04d9d89350ab1394cc0c168147 SHA512 8a42df63911000cd119da33e7fea25fa1a5244a86016818bcb6c6e12c042b12b00b7272633d85dcf921fd2eba67145e3258c64689be799a0f59766e541139120
DIST hiredis-py-2.2.3.gh.tar.gz 18214 BLAKE2B cdac5e9790c88657c75be721c4dbc91174a0eb38cdd790076b3ec1f009d43c7aef300bfa7381a10061749cb3bec02d4a488e732f550bea4c62893aabfc0c3222 SHA512 e85032869b6bbbc30f991d83d67a710c04998645517b1ddcfd801ff37bd28f0576a5bdc2986f3526f72da8448986714a79b42a0ab1a5cc6b6bab24f3d98fdce9
45 changes: 45 additions & 0 deletions dev-python/hiredis/hiredis-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_EXT=1
DISTUTILS_USE_PEP517="setuptools"
PYTHON_COMPAT=( python3_{9..11} pypy3 )

inherit distutils-r1

MY_P=hiredis-py-${PV}
DESCRIPTION="Python extension that wraps hiredis"
HOMEPAGE="
https://github.com/redis/hiredis-py/
https://pypi.org/project/hiredis/
"
SRC_URI="
https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"

DEPEND="
>=dev-libs/hiredis-1.0.0:=
"
RDEPEND="
${DEPEND}
"

PATCHES=(
"${FILESDIR}"/hiredis-2.2.2-system-libs.patch
)

distutils_enable_tests pytest

python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
rm -rf hiredis || die
epytest
}

0 comments on commit 59e4c93

Please sign in to comment.