Skip to content

Commit

Permalink
kde-frameworks/kpackage: Add fix for <=Plasma-5.8
Browse files Browse the repository at this point in the history
5.28.0 left users with a broken desktop without pre-existing config.

Package-Manager: portage-2.3.0
  • Loading branch information
a17r authored and Michael Palimaka committed Nov 18, 2016
1 parent a696605 commit 59e9c47
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From e7861d979c71815a614f2baf0b3d25f329fadef0 Mon Sep 17 00:00:00 2001
From: Marco Martin <[email protected]>
Date: Fri, 18 Nov 2016 15:51:49 +0100
Subject: keep installing metadata.desktop

there are too many existing users that rely on existence of metadata.desktop,
so keep installing it, even if with new plasma-workspace releases only the
metadata.json would be used. the framework should never change its behavior
wrt old software, even if it was doing something in a sense wrong
CCMAIL: Aleix Pol Gonzalez <[email protected]>
BUG:372594
---
KF5PackageMacros.cmake | 1 -
1 file changed, 1 deletion(-)

diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
index cc5aae2..a14ab0b 100644
--- a/KF5PackageMacros.cmake
+++ b/KF5PackageMacros.cmake
@@ -31,7 +31,6 @@ function(kpackage_install_package dir component)
set(install_dir ${KPACKAGE_RELATIVE_DATA_INSTALL_DIR})
endif()
install(DIRECTORY ${dir}/ DESTINATION ${KDE_INSTALL_DATADIR}/${install_dir}/${root}/${component}
- PATTERN metadata.desktop EXCLUDE
PATTERN .svn EXCLUDE
PATTERN CMakeLists.txt EXCLUDE
PATTERN Messages.sh EXCLUDE
--
cgit v0.11.2

32 changes: 32 additions & 0 deletions kde-frameworks/kpackage/kpackage-5.28.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit kde5

DESCRIPTION="Framework to install and load packages of non binary content"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="man"

RDEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep ki18n)
"
DEPEND="${RDEPEND}
man? ( $(add_frameworks_dep kdoctools) )
"

PATCHES=( "${FILESDIR}/${P}-install-metadata.patch" ) # fix for <=Plasma-5.8

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package man KF5DocTools)
)

kde5_src_configure
}

0 comments on commit 59e9c47

Please sign in to comment.