Skip to content

Commit

Permalink
dev-vcs/mercurial: Bump to version 4.1.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed Apr 4, 2017
1 parent dfdbac9 commit 59f09f5
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/mercurial/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mercurial-3.8.4.tar.gz 4775341 SHA256 4b2e3ef19d34fa1d781cb7425506a05d4b6b1172bab69d6ea78874175fdf3da6 SHA512 2ee785f631f9ae346e10ca77251a9ce6d3dacd598588c39f1a69ce1f4b668866f6109d682428512c37c300b26741b74672195538d66845e85cfff5ead886cf4c WHIRLPOOL 1f0a12cc6d00f3544ab00e011a9ff9308fe1652c0598045ddba2a41ba17b55c291da200bce85d4c600d673b8746e936c441ffa7398ad810d1069bd97fb32f2db
DIST mercurial-4.1.1.tar.gz 5132169 SHA256 63571be1202f83c72041eb8ca2a2ebaeda284d2031fd708919fc610589d3359e SHA512 b076336a10d524e85a7eb46e0da7b1b5adb34ca377ec162ebf0b3fc1f3749db10bd9144ce046dda63aa0e6ad65d10e288919d65a88d5a9346b26a47d4b21bd49 WHIRLPOOL a5679e03249dbb840de08ec024afa45f4023b6e001abb0a26960d135aa05ca327e1ee6222c9cdcc99af343168a93f5016346bd19624fd83c608a81dd9f078500
DIST mercurial-4.1.2.tar.gz 5133417 SHA256 09415253fb409a77e19b9951532a3c22c4e07e74bab80652527064617daab194 SHA512 32b59d23d6b911b7a7e9c9c7659457daf2eba771d5170ad5a44a068d7941939e1d68c72c847e488bf26c14392e5d7ee25e5f660e0330250d0685acce40552745 WHIRLPOOL 33f9b284334f2a35f52e998842ebb71c515f22dc3429f93626aa2dcb05b892f83ae8352068f4ef8a7c4a89f2f3bacec248bd8b310b29250cdc2092af9dfeae81
DIST mercurial-4.1.tar.gz 5125009 SHA256 7b33c32cdd1d518bc2e2ae223e6ef63c486cf52e9d01a45b99cf8eab7bea5274 SHA512 02e4aabe47473194961870909d4512a4be6814cccb51b727dfa9a34dd0aa5f92bfad7b03e6b58ce6c7e2531df52dac530f02264df28dcfc801036fe103cd4471 WHIRLPOOL 9fc1bfdc0f1515122edaa0d342427709e4a3aa87dcd6315d33328fed25cb5e6aad143774e294363db33f38dda2aa87c4eb4a785efd55550768abca4422850c1f
134 changes: 134 additions & 0 deletions dev-vcs/mercurial/mercurial-4.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic

DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="bugzilla emacs gpg test tk"

RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}] )"

SITEFILE="70${PN}-gentoo.el"

PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )

python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die

distutils-r1_python_prepare_all
}

python_configure_all() {
strip-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing

"${PYTHON}" setup.py build_mo || die
}

python_compile_all() {
rm -r contrib/{win32,macosx} || die
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}

python_install_all() {
distutils-r1_python_install_all

newbashcomp contrib/bash_completion hg

insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg

rm -f doc/*.?.txt
dodoc CONTRIBUTORS
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die

dobin hgeditor
dobin contrib/hgk
python_foreach_impl python_doscript contrib/hg-ssh

if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi

local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/$f || die
done

dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?

insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}

src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
#rm -f test-doctest* # doctest always fails with python 2.5.x
rm -f test-largefiles* # tends to time out

popd &>/dev/null || die
distutils-r1_src_test
}

python_test() {
local TEST_DIR

rm -rf "${TMPDIR}"/test
distutils_install_for_testing
cd tests || die
"${PYTHON}" run-tests.py --verbose \
--tmpdir="${TMPDIR}"/test \
--with-hg="${TEST_DIR}"/scripts/hg \
|| die "Tests fail with ${EPYTHON}"
}

pkg_postinst() {
use emacs && elisp-site-regen

elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 59f09f5

Please sign in to comment.