Skip to content

Commit

Permalink
games-strategy/outerspace: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed May 2, 2018
1 parent 12d1242 commit 5a239ce
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 4 deletions.
8 changes: 4 additions & 4 deletions games-strategy/outerspace/files/outerspace-0.5.68-setup.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- setup.py
+++ setup.py
--- a/setup.py
+++ b/setup.py
@@ -42,12 +42,7 @@

# collect data files
Expand Down Expand Up @@ -42,8 +42,8 @@
- os.remove(path)
-
-shutil.rmtree("libsrvr", onerror = onerror)
--- osc.py
+++ osc.py
--- a/osc.py
+++ b/osc.py
@@ -23,12 +23,36 @@
# tweak PYTHONPATH
import sys
Expand Down
72 changes: 72 additions & 0 deletions games-strategy/outerspace/outerspace-0.5.68-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit desktop gnome2-utils distutils-r1

MY_PN="${PN/outerspace/Outer Space}"
DESCRIPTION="On-line strategy game taking place in the dangerous universe"
HOMEPAGE="http://www.ospace.net/"
SRC_URI="mirror://sourceforge/ospace/Client/${PV}/Outer%20Space-${PV}.tar.gz -> ${P}.tar.gz
mirror://sourceforge/ospace/Client/${PV}/outerspace_${PV}-0ubuntu1_all.deb"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=dev-python/pygame-1.7"
DEPEND=""

S="${WORKDIR}/${MY_PN}-${PV}"

src_unpack() {
default
unpack ./data.tar.gz
}

python_install() {
distutils-r1_python_install \
--install-scripts="/usr/bin" \
--install-data="/usr/share/${PN}" \
--install-lib="$(python_get_sitedir)"

# source tarball is missing files
# get them from ubuntu.deb
insinto "$(python_get_sitedir)"/ige/ospace/Rules
doins "${WORKDIR}"/usr/share/games/outerspace/libsrvr/ige/ospace/Rules/{Tech,techs}.spf
}

src_prepare() {
default

# fix setup script
# rework python start script to avoid shell-wrapper script
eapply "${FILESDIR}"/${P}-setup.patch

sed -i\
-e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
osc.py || die "sed failed"

distutils-r1_src_prepare
}

src_install() {
distutils-r1_src_install
newicon res/logo-login.png ${PN}.png
make_desktop_entry "osc.py" "${MY_PN}"
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 5a239ce

Please sign in to comment.