Skip to content

Commit

Permalink
games-arcade/cdogs-sdl: add 1.3.0
Browse files Browse the repository at this point in the history
Also add CC-BY-4.0 (lmg.mp3) and WTFPL-2 (easing.c) to LICENSE, and
[mp3] to sdl2-mixer.

Remove CMAKE_IN_SOURCE_BUILD workaround, no longer necessary.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed May 3, 2022
1 parent 24f50fc commit 5a2daa6
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/cdogs-sdl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cdogs-sdl-1.2.0.tar.gz 35018104 BLAKE2B 1a87f0c6e4af0fda69c0dd98249b319b58411a5b0b7377c21ebef51939f2b6e76959a00bf7fd5602b07bebb9eaab22c840699ae1c54e5d4dcb1aa26852fb8ba0 SHA512 70a5a4bb8e48cf53a4497807b14d8a70e26ad6b74f0c4675b3d98667c867d499d372f323e7abb669ebef08b1d6b5ac9c840ab14eada38e7b868d3099ed6b3e35
DIST cdogs-sdl-1.3.0.tar.gz 35201522 BLAKE2B bdfeab22edc0e5bfe46d23862bb0e8a829eb8c782519f473340a73d6823fcf6236d61892dff5f6be52e985a8560ce2175b5aab50fb899359d47d3acdf937fe5d SHA512 913ee8a70ab2190259a88891e4f3e30034b7a88dac5fa1a79fcc9452a42fe9fa6679e24104848fab63c7aace8dac311d2166fa01c7175f14243d8658f25aee69
44 changes: 44 additions & 0 deletions games-arcade/cdogs-sdl/cdogs-sdl-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake xdg

DESCRIPTION="Classic overhead run-and-gun game"
HOMEPAGE="https://cxong.github.io/cdogs-sdl/"
SRC_URI="https://github.com/cxong/cdogs-sdl/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+ BSD-2 CC-BY-3.0 CC-BY-4.0 CC-BY-SA-3.0 CC0-1.0 WTFPL-2 XMAME"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
media-libs/libsdl2[haptic,opengl]
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[mp3,vorbis,wav]
net-libs/enet:1.3="
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-1.1.1-cmake.patch
)

src_configure() {
local mycmakeargs=(
-DCDOGS_DATA_DIR="${EPREFIX}"/usr/share/${PN}/
-DBUILD_EDITOR=OFF
-DUSE_SHARED_ENET=ON
)

cmake_src_configure
}

src_install() {
cmake_src_install

dodoc doc/{AUTHORS,original_readme.txt}

# CREDITS is used at runtime, rest is licenses or duplicates
find "${ED}"/usr/share/${PN}/doc -type f ! -name CREDITS -delete || die
}

0 comments on commit 5a2daa6

Please sign in to comment.