Skip to content

Commit

Permalink
dev-db/sqlitebrowser: Version bump (thanks Fabio Rossi, bug 571048).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
xmw committed Jan 10, 2016
1 parent d384b18 commit 5a30381
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/sqlitebrowser/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sqlitebrowser-3.7.0.tar.gz 1509766 SHA256 3093a1dcf5b3138c1adf29857d62249ab2b068e70b001869a31151763e28cc3a SHA512 f4c2f517a0b04fb74d8ec656e34f93d467a233040b36fab8f6f172681eb213be5c08131ecdaaa542d833bf24ef564d8e6f800e861b9a20d53de7a585aa104533 WHIRLPOOL 3bbfaa99f179c10f542d344ce6fe55656aa750a52925b2de590e2ba24bcafa95604646e6b218bca4f461390268de2bc2fb29d0de1deaf06438b33cb660e614e8
DIST sqlitebrowser-3.8.0.tar.gz 1538043 SHA256 f638a751bccde4bf0305a75685e2a72d26fc3e3a69d7e15fd84573f88c1a4d92 SHA512 6e262e3bd3b26a1574a69cc9f306774cc9fe69f87c3253aba6b40c35f2491bc0636b6d5e705526e039ee9d8ed27d21a4529a624d62e8879a3917cfb502a65589 WHIRLPOOL 35d3594643a65e6b69bec816430dab3017c3ba197a12ab56ed9f027525db02a635789fda723bbd823d2f66b3933ee2381181ea7e95151be515cf1ddceeb9c8f9
60 changes: 60 additions & 0 deletions dev-db/sqlitebrowser/sqlitebrowser-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

CMAKE_MAKEFILE_GENERATOR=ninja

inherit eutils cmake-utils

DESCRIPTION="SQLite Database Browser"
HOMEPAGE="http://sqlitebrowser.org"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3 MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="qt4 qt5 test"

REQUIRED_USE="^^ ( qt4 qt5 )"

RDEPEND="
dev-cpp/antlr-cpp:2=
dev-db/sqlite:3
dev-libs/qcustomplot[qt5=]
x11-libs/qscintilla
qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
)
qt5? (
dev-qt/qtnetwork:5
dev-qt/qttest:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
qt5? ( dev-qt/linguist-tools:5 )
"

PATCHES=( "${FILESDIR}"/${PN}-3.7.0-unbundle.patch )

src_prepare() {
# https://github.com/qingfengxia/qhexedit still bundled
# x11-libs/qscintilla[qt4?,qt5?] still bundled
find libs/{antlr-2.7.7,qcustomplot-source} -delete || die
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_use qt5)
$(cmake-utils_use_enable test TESTING)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
doicon images/sqlitebrowser.svg
}

0 comments on commit 5a30381

Please sign in to comment.