forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST libzia-4.14.tar.gz 597138 BLAKE2B 200e0682c6bc28248646775c5e5a71bad329edf031d0950ad8ab5244e5e925903147467d23eb3a04f9be05cca6b34947692df15620331ffc5357b73f20d363b0 SHA512 c382ef352e80df69daf3d3e4da0c0de5d8037b32182a760f88a1edf7d2b9cc7d5112de942a5a85973ccf82ca1e0771c2e92de7972ff9bec745fdb525419a2365 | ||
DIST libzia-4.15.tar.gz 600728 BLAKE2B 7e359a09c9e440c65fe369a8ff9004883ecbc047cfa4995e671c74662f9658370e0e8f613e626f9480abb9fb6d94e777bde70b44d080d45f4e17b1f982c48237 SHA512 041e21e1506b4cc38a0b9a5fa07037de01d19a390b6ba46159688b2bd7c75c44faf6e84d1ec929a582a2c8038c60f986d6d172636b5e9cb1b2fc5a729ec2225f | ||
DIST libzia-4.16.tar.gz 623606 BLAKE2B 48c5eb65890c87ed48bfaee60a6683f5320c561c8f6bf55268690675e388aefeb52e229c16430b9ff04b8ae29749e52beb71ac7d7f0642f4fa255e1bef85b452 SHA512 cbf0e678abadd670acde1778dcb137a49ad11f8e8d8d8465ebac542deb964e1c138b65ebf61404ea0219e17cdb336585545eee3f63d4e0ac41bffe0010f2c2fb |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit autotools | ||
|
||
DESCRIPTION="platform abstraction code for tucnak package" | ||
HOMEPAGE="http://tucnak.nagano.cz" | ||
SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="ftdi" | ||
|
||
RDEPEND="dev-libs/glib:2 | ||
x11-libs/gtk+:2 | ||
media-libs/libsdl | ||
media-libs/libpng:0 | ||
ftdi? ( dev-embedded/libftdi:0 )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
MAKEOPTS+=" -j1" | ||
|
||
src_prepare() { | ||
eapply_user | ||
sed -i -e "s/docsdir/#docsdir/g" \ | ||
-e "s/docs_/#docs_/g" Makefile.am || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_with ftdi) --with-sdl \ | ||
--with-png --without-bfd | ||
} |