Skip to content

Commit

Permalink
kde-apps/kdepim-runtime: Fix ical data loss
Browse files Browse the repository at this point in the history
Revision bump adds upstream patch reported on release mailing list.

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
johu committed Dec 19, 2016
1 parent 3c92b41 commit 5a888b5
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
commit 8ae09b6f4afa8ceb2770da67b6dc79c78b86af47
Author: David Faure <[email protected]>
Date: Mon Dec 19 13:29:30 2016 +0100

Fix DATA LOSS bug in ical resource which failed to create std.ics if it didn't exist.

The default setup sets the Path to be a local path, not a URL.
=> Use QUrl::fromUserInput so that it can deal with both cases, paths and URLs.

CCMAIL: [email protected], [email protected]

diff --git a/resources/shared/singlefileresource/singlefileresource.h b/resources/shared/singlefileresource/singlefileresource.h
index f3c19aaf5..3f4149903 100644
--- a/resources/shared/singlefileresource/singlefileresource.h
+++ b/resources/shared/singlefileresource/singlefileresource.h
@@ -55,7 +55,7 @@ public:
, mSettings(new Settings(config()))
{
// The resource needs network when the path refers to a non local file.
- setNeedsNetwork(!QUrl(mSettings->path()).isLocalFile());
+ setNeedsNetwork(!QUrl::fromUserInput(mSettings->path()).isLocalFile());
}
~SingleFileResource()
{
@@ -82,7 +82,7 @@ public:
return;
}

- mCurrentUrl = QUrl(mSettings->path()); // path already has scheme
+ mCurrentUrl = QUrl::fromUserInput(mSettings->path()); // the string contains the scheme if remote, doesn't if local path
if (mCurrentHash.isEmpty())
{
// First call to readFile() lets see if there is a hash stored in a
87 changes: 87 additions & 0 deletions kde-apps/kdepim-runtime/kdepim-runtime-16.12.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

KDE_HANDBOOK="forceoptional"
KDE_TEST="forceoptional"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
LICENSE="GPL-2+ LGPL-2.1+"
KEYWORDS="~amd64 ~x86"
IUSE="google ssl"

# TODO kolab, Qt5TextToSpeech

CDEPEND="
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep knotifyconfig)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwallet)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_kdeapps_dep akonadi)
$(add_kdeapps_dep akonadi-calendar)
$(add_kdeapps_dep akonadi-contacts)
$(add_kdeapps_dep akonadi-mime)
$(add_kdeapps_dep akonadi-notes)
$(add_kdeapps_dep kalarmcal)
$(add_kdeapps_dep kcalcore)
$(add_kdeapps_dep kcalutils)
$(add_kdeapps_dep kcontacts)
$(add_kdeapps_dep kidentitymanagement)
$(add_kdeapps_dep kimap)
$(add_kdeapps_dep kmailtransport)
$(add_kdeapps_dep kmbox)
$(add_kdeapps_dep kmime)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
$(add_qt_dep qtxmlpatterns)
dev-libs/libical:=
google? ( >=net-libs/libkgapi-5.1.0:5 )
ssl? ( dev-libs/cyrus-sasl )
"
DEPEND="${CDEPEND}
$(add_frameworks_dep kross)
dev-libs/cyrus-sasl:2
dev-libs/libxslt
x11-misc/shared-mime-info
"
RDEPEND="${CDEPEND}
!kde-apps/kdepim-kioslaves
$(add_frameworks_dep oxygen-icons)
"

RESTRICT+=" test"

PATCHES=( "${FILESDIR}/${P}-ical-data-loss.patch" )

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package google KF5GAPI)
$(cmake-utils_use_find_package ssl Sasl2)
)

kde5_src_configure
}

0 comments on commit 5a888b5

Please sign in to comment.