Skip to content

Commit

Permalink
dev-java/commons-launcher: EAPI 5 bump. Switch to java-pkg-simple.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
monsieurp committed Apr 5, 2016
1 parent 163463d commit 5aa49ef
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-java/commons-launcher/commons-launcher-1.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

JAVA_PKG_IUSE="examples doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Commons-launcher eliminates the need for a batch or shell script to launch a Java class"
HOMEPAGE="http://commons.apache.org/launcher/"
SRC_URI="mirror://apache/${PN%%-*}/${PN##*-}/source/${P}-src.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE=""

CDEPEND="dev-java/ant-core:0"

RDEPEND="
${CDEPEND}
>=virtual/jre-1.6"

DEPEND="
${CDEPEND}
>=virtual/jdk-1.6
source? ( app-arch/zip )"

S="${WORKDIR}/${PN}"

JAVA_GENTOO_CLASSPATH="ant-core"

JAVA_SRC_DIR="src"

java_prepare() {
java-pkg_clean
}

src_install() {
java-pkg-simple_src_install
use examples && java-pkg_doexamples example
}

0 comments on commit 5aa49ef

Please sign in to comment.