Skip to content

Commit

Permalink
x11-terms/gnome-terminal: bump to 3.32.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
leio committed Sep 28, 2019
1 parent fe8834e commit 5b1f6e6
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
2 changes: 2 additions & 0 deletions x11-terms/gnome-terminal/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST gnome-terminal-3.30.2-notify-open-title-transparency.patch.xz 31748 BLAKE2B 6a25547fcdd387ea90c3ba13e53f31a118cc01c50c72f1f597162452ea65509e2fc8adaa2f6487859d8a53e828173d77a6f952d172f5a685e2b51864a82cce7f SHA512 51f32879c93a5ca489db9a604b28585787c9ec1a444c5e8c76bf26edeaa68e35fe9f76f94f32e99716a0d01643ac859475be13232c62675c703b5503781cb8d0
DIST gnome-terminal-3.30.3.tar.xz 2102108 BLAKE2B 1930bc97c8d77d0107dbb7e56d849e3941c6821863d25103d8d17135d334b6ceda5b5ef1cad81d02011fb7190fd5b39ce4176083af0af6bebb71f52e30cd2c7b SHA512 54d3b345a23905f65ccc7d238b2f9ebcfebc4ccccf504c41bdb3dc388ceee8e6f2dfbba7c0060ea6bcba8bb541a031fe619d462e024aef277f66b5c49792c291
DIST gnome-terminal-3.32.2-cntr-ntfy-ttl-ts.patch.xz 31684 BLAKE2B 34c3473632d82983aec98a867e7353829521527f8f570e62e5fd7a1bd638b470c6f1ce7fde33d4604a2ca40e4b93be02a22dbdd4d1559a03bf230060310e81bf SHA512 76732fd57644431936b78a3ea3e8010b3f14fb0af52fa9c79540ed5ec5a0a45e6b31c9ace2b67a02559ec4e294927bf2033730d074727c3fe05054f39d1a8b42
DIST gnome-terminal-3.32.2.tar.xz 2039236 BLAKE2B 967f87a362cf893c8d743caefc9b857d6c8092e59c3ce77a76dea5d50f503bea9c9e066e447724b6c7781bec808a4cccf8c3d646ecccb1800da9a0bdd7f28e4d SHA512 1be1e26b62b9364361982a34455fb5c818a2114edadb1146985f9e418ce5d51387d12b443c12022b8eec9c61c2137a1a780f390672406a1940f8b352b782e3cc
84 changes: 84 additions & 0 deletions x11-terms/gnome-terminal/gnome-terminal-3.32.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
GNOME2_LA_PUNT="yes"

inherit gnome2 readme.gentoo-r1

DESCRIPTION="The Gnome Terminal"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"

LICENSE="GPL-3+"
SLOT="0"
IUSE="debug +gnome-shell +nautilus vanilla"
SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/${P}-cntr-ntfy-ttl-ts.patch.xz )"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"

# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
RDEPEND="
>=dev-libs/glib-2.42:2
>=x11-libs/gtk+-3.20:3
>=x11-libs/vte-0.56.2:2.91[!vanilla?]
>=dev-libs/libpcre2-10
>=gnome-base/dconf-0.14
>=gnome-base/gsettings-desktop-schemas-0.1.0
sys-apps/util-linux
gnome-shell? ( gnome-base/gnome-shell )
nautilus? ( >=gnome-base/nautilus-3 )
"
# itstool required for help/* with non-en LINGUAS, see bug #549358
# xmllint required for glib-compile-resources, see bug #549304
DEPEND="${RDEPEND}
dev-libs/libxml2:2
dev-util/gdbus-codegen
dev-util/glib-utils
>=dev-util/intltool-0.50
dev-util/itstool
sys-devel/gettext
virtual/pkgconfig
"

DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
notifications of long-running commands finishing, you will need
to add the following line to your ~/.bashrc:\n
. /etc/profile.d/vte-2.91.sh"

src_prepare() {
if ! use vanilla; then
# https://bugzilla.gnome.org/show_bug.cgi?id=695371
# Fedora patches:
# Restore transparency support (with compositing WMs only)
# OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
# Restore "Set title" support
# http://pkgs.fedoraproject.org/cgit/rpms/gnome-terminal.git/plain/gnome-terminal-notify-open-title-transparency.patch
# Depends on vte[-vanilla] for OSC 777 patch in VTE
eapply "${WORKDIR}"/${P}-cntr-ntfy-ttl-ts.patch
fi
gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
--disable-static \
$(use_enable debug) \
$(use_enable gnome-shell search-provider) \
$(use_with nautilus nautilus-extension)
}

src_install() {
DOCS="AUTHORS ChangeLog HACKING NEWS"
gnome2_src_install
if ! use vanilla; then
# Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
insinto /usr/share/glib-2.0/schemas
newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
fi
readme.gentoo_create_doc
}

pkg_postinst() {
gnome2_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit 5b1f6e6

Please sign in to comment.