Skip to content

Commit

Permalink
dev-ros/xmlrpcpp: Install headers in a prefixed directory.
Browse files Browse the repository at this point in the history
Fixes collisions with heimdal, bug #561208.

Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Nov 2, 2015
1 parent 14d1733 commit 5b240aa
Show file tree
Hide file tree
Showing 3 changed files with 31 additions and 0 deletions.
15 changes: 15 additions & 0 deletions dev-ros/xmlrpcpp/files/headers.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
Index: ros_comm-1.11.15/utilities/xmlrpcpp/CMakeLists.txt
===================================================================
--- ros_comm-1.11.15.orig/utilities/xmlrpcpp/CMakeLists.txt
+++ ros_comm-1.11.15/utilities/xmlrpcpp/CMakeLists.txt
@@ -30,9 +30,8 @@ if(WIN32)
target_link_libraries(xmlrpcpp ws2_32)
endif()

-# FIXME the headers should be in a package-specific subfolder but can not be for backward compatibility
install(DIRECTORY include/
- DESTINATION ${CATKIN_GLOBAL_INCLUDE_DESTINATION}
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
FILES_MATCHING PATTERN "*.h")

install(TARGETS xmlrpcpp
Original file line number Diff line number Diff line change
Expand Up @@ -17,3 +17,11 @@ IUSE=""

RDEPEND="dev-ros/cpp_common"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/headers.patch" )

src_configure() {
ros-catkin_src_configure
# Hack so that proper -I are added
sed -e "s#_include_dirs \"include\"#_include_dirs \"include;${SYSROOT:-${EPREFIX}}/usr/include/xmlrpcpp\"#" \
-i "${BUILD_DIR}/catkin_generated/installspace/xmlrpcppConfig.cmake" || die
}
8 changes: 8 additions & 0 deletions dev-ros/xmlrpcpp/xmlrpcpp-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -17,3 +17,11 @@ IUSE=""

RDEPEND="dev-ros/cpp_common"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/headers.patch" )

src_configure() {
ros-catkin_src_configure
# Hack so that proper -I are added
sed -e "s#_include_dirs \"include\"#_include_dirs \"include;${SYSROOT:-${EPREFIX}}/usr/include/xmlrpcpp\"#" \
-i "${BUILD_DIR}/catkin_generated/installspace/xmlrpcppConfig.cmake" || die
}

0 comments on commit 5b240aa

Please sign in to comment.