Skip to content

Commit

Permalink
sys-kernel/vanilla-kernel: Bump to 5.8.13
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Oct 1, 2020
1 parent 4215242 commit 5b58b6f
Show file tree
Hide file tree
Showing 2 changed files with 128 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/vanilla-kernel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -11,3 +11,4 @@ DIST linux-5.4.66.tar.xz 109584352 BLAKE2B 5b2f08dfac6069f2a5a842de69b572691d4d6
DIST linux-5.4.68.tar.xz 109601148 BLAKE2B 03e25fdfa93a892aa7b8ea0ba4822c1dbf1f8cb498cdb80b3c3f4f8ea2b7d4f02bcecdf3788afc84dd1fbd4de02add0c2a5f9e5d9ededaa02fff4bf5e8310300 SHA512 027f63296a2b3a0fda3eaeed8ac1a3e0075d90469888c76666f355a69f2c81384e9245d31991f74f6fbba657d35ba32bf280a455e7b5abd68b039990f5f8efaa
DIST linux-5.4.69.tar.xz 109603628 BLAKE2B 8a9b8e44b5a1ae69a4422f22b31c48ea1cf0ccf4b7fe55baa8e68b4797f717b66b38f739a5e525455ce9ecf99fdf312275a856d7f6956f17f3ffbb10a749ab63 SHA512 3a161bce688b1e9d18703f6354b746d1e8c72dcbbf6e3c8759a98ef3611234a32d7e571977aa78f33db9d42cfd9ad82145f3faea028d335a1863eb624b940b6c
DIST linux-5.8.12.tar.xz 114510484 BLAKE2B 85edb8bea54dc1952e7f3ec439d01b22181ac9ba527ca387a04168966398e615a052d7d9585cde47fa4a4f9f09a7dffffaa41508af9b0cb7c93357e9f54ecf15 SHA512 c1daa20dcdaa2cb805e7a973b684ea40327088d8fadf0cf44f4c73284923363397b12f2e1958d64d6a0ff348198366d46b59a5301a72d3431389d319a4bde489
DIST linux-5.8.13.tar.xz 114511960 BLAKE2B 1b3510440d07032fd38beec3f325fee6cde73ba07f2fa4d0e220c3d86069a21852a9dd16cdb993a714c12eee2a3eff02f13504326f83354126f02ee399205d92 SHA512 38c5c70b4327e1f0a46bde8acac5350882aaeb1308e5e88e5d8fbc229011ea03dca76489a8413c541bedc28a446f6453e3410afa5e84cde6a57d21ec783e6f27
127 changes: 127 additions & 0 deletions sys-kernel/vanilla-kernel/vanilla-kernel-5.8.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,127 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-build

MY_P=linux-${PV}
# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
CONFIG_VER=5.8.5
CONFIG_HASH=af8da8d54d21231fd8c7b943216bb985f0a4e223

DESCRIPTION="Linux kernel built from vanilla upstream sources"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
amd64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
-> kernel-x86_64-fedora.config.${CONFIG_VER}
)
arm64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
-> kernel-aarch64-fedora.config.${CONFIG_VER}
)
ppc64? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le-fedora.config
-> kernel-ppc64le-fedora.config.${CONFIG_VER}
)
x86? (
https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
-> kernel-i686-fedora.config.${CONFIG_VER}
)"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="debug"
REQUIRED_USE="
arm? ( savedconfig )"

RDEPEND="
!sys-kernel/vanilla-kernel-bin:${SLOT}"
BDEPEND="
debug? ( dev-util/dwarves )"

pkg_pretend() {
ewarn "Starting with 5.7.9, Distribution Kernels are switching from Arch"
ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."

kernel-install_pkg_pretend
}

src_prepare() {
default

# prepare the default config
case ${ARCH} in
amd64)
cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
;;
arm)
return
;;
arm64)
cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
;;
ppc64)
cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
;;
x86)
cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
;;
*)
die "Unsupported arch ${ARCH}"
;;
esac

local config_tweaks=(
# replace (none) with gentoo
-e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
# we do support x32
-e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
# disable signatures
-e '/CONFIG_MODULE_SIG/d'
-e '/CONFIG_SECURITY_LOCKDOWN/d'
-e '/CONFIG_KEXEC_SIG/d'
-e '/CONFIG_KEXEC_BZIMAGE_VERIFY_SIG/d'
-e '/CONFIG_SYSTEM_EXTRA_CERTIFICATE/d'
-e '/CONFIG_SIGNATURE/d'
# remove massive array of LSMs
-e 's/CONFIG_LSM=.*/CONFIG_LSM="yama"/'
-e 's/CONFIG_DEFAULT_SECURITY_SELINUX=y/CONFIG_DEFAULT_SECURITY_DAC=y/'
# nobody actually wants fips
-e '/CONFIG_CRYPTO_FIPS/d'
# these tests are really not necessary
-e 's/.*CONFIG_CRYPTO_MANAGER_DISABLE_TESTS.*/CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=y/'
# probably not needed by anybody but developers
-e '/CONFIG_CRYPTO_STATS/d'
# 1000hz is excessive for laptops
-e 's/CONFIG_HZ_1000=y/CONFIG_HZ_300=y/'
# nobody is using this kernel on insane super computers
-e 's/CONFIG_NR_CPUS=.*/CONFIG_NR_CPUS=512/'
# we're not actually producing live patches for folks
-e 's/CONFIG_LIVEPATCH=y/CONFIG_LIVEPATCH=n/'
# this slows down networking in general
-e 's/CONFIG_IP_FIB_TRIE_STATS=y/CONFIG_IP_FIB_TRIE_STATS=n/'
# include font for normal and hidpi screens
-e 's/.*CONFIG_FONTS.*/CONFIG_FONTS=y\nCONFIG_FONT_8x16=y\nCONFIG_FONT_TER16x32=y/'
# we don't need to actually install system headers from this ebuild
-e '/CONFIG_HEADERS_INSTALL/d'
# enable /proc/config.gz, used by linux-info.eclass
-e '/CONFIG_IKCONFIG/s:.*:CONFIG_IKCONFIG=y\nCONFIG_IKCONFIG_PROC=y:'
)
use debug || config_tweaks+=(
-e '/CONFIG_DEBUG_INFO/d'
-e '/CONFIG_DEBUG_RODATA_TEST/d'
-e '/CONFIG_DEBUG_VM/d'
-e '/CONFIG_DEBUG_SHIRQ/d'
-e '/CONFIG_DEBUG_LIST/d'
-e '/CONFIG_BUG_ON_DATA_CORRUPTION/d'
-e '/CONFIG_TORTURE_TEST/d'
-e '/CONFIG_BOOTTIME_TRACING/d'
-e '/CONFIG_RING_BUFFER_BENCHMARK/d'
-e '/CONFIG_X86_DECODER_SELFTEST/d'
-e '/CONFIG_KGDB/d'
)
sed -i "${config_tweaks[@]}" .config || die
}

0 comments on commit 5b58b6f

Please sign in to comment.