Skip to content

Commit

Permalink
dev-python/bracex: add 2.3_p1
Browse files Browse the repository at this point in the history
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
Nowa-Ammerlaan committed Jun 1, 2022
1 parent 5285e9f commit 5b85366
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/bracex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bracex-2.2.1.tar.gz 27642 BLAKE2B e9eb12dd70b3cf1c6abd8a59f19d8f77f8fc85e07efad02a2c0213266b93641406d05fa8454b2b4cd6870b7f866a22c0b2132d690444f1910a599c9b17594065 SHA512 cad9faf73258493581606bf5c8068d34a82fdcca338dd6a1d7da5dacfbee1932f48d04d6f295151d79f02495ddf89aa6a5d53d6596db7bd53ddb3cd23d59a71d
DIST bracex-2.3.tar.gz 27489 BLAKE2B c48b668c35d40337fe9096c8fbc67565ea74abf330a278e1fe070055fcf8835a60dc23fba40c0f1c0677d506c7d8f8ca5168f809b13ab0442868bc962faaf1d5 SHA512 73f3b951ce1119154794883106a317e9ed4bbe8d96dc914afb6ca6d358104ae4908bc587504e2761c751a3795adf7f2136e96a2d46634b10478c7523fbee4f60
DIST bracex-2.3_p1.tar.gz 27541 BLAKE2B a9e33e01f014c6b784b059a76da338a708a24ff88787c98c0916a6d13ac5497a1f4f14d711cab8bde1281a9968db68bdc8fdfbc23a531ef6c89adfa9974492b1 SHA512 3c5a8a81adb78c9d3d40b57328a6a47b3257bb0072be2685c8049cf8a91501993ce470dfd394a61d0a0fdcd082405b204e5e3e0666018978b5aa820b0d74b631
56 changes: 56 additions & 0 deletions dev-python/bracex/bracex-2.3_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_USE_PEP517=hatchling

DOCS_BUILDER="mkdocs"
DOCS_DEPEND="
dev-python/mkdocs-git-revision-date-localized-plugin
dev-python/mkdocs-material
dev-python/mkdocs-minify-plugin
dev-python/mkdocs_pymdownx_material_extras
dev-python/pyspelling
"

inherit distutils-r1 docs

MY_PV="${PV%_p1}.post1"

DESCRIPTION="Bash style brace expansion for Python"
HOMEPAGE="
https://github.com/facelessuser/bracex/
https://pypi.org/project/bracex/
"
SRC_URI="
https://github.com/facelessuser/${PN}/archive/${MY_PV}.tar.gz
-> ${P}.tar.gz
"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"

BDEPEND="
test? (
dev-vcs/git
)
"

distutils_enable_tests pytest

python_prepare_all() {
# mkdocs-git-revision-date-localized-plugin needs git repo
if use doc; then
git init || die
git config --global user.email "[email protected]" || die
git config --global user.name "Your Name" || die
git add . || die
git commit -m 'init' || die
fi

distutils-r1_python_prepare_all
}

0 comments on commit 5b85366

Please sign in to comment.